diff mbox series

[bug#66889,1/2] gnu: Add pcg-c.

Message ID 1c639973fbed48a27da78c45d4332f3cae458738.1698878711.git.david.elsing@posteo.net
State New
Headers show
Series Unbundle igraph dependencies. | expand

Commit Message

David Elsing Nov. 1, 2023, 10:57 p.m. UTC
* gnu/packages/c.scm (pcg-c): New variable.
---
 gnu/packages/c.scm | 55 ++++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index ea58c68262..0c218b9656 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023 David Elsing <david.elsing@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1585,3 +1586,57 @@  (define-public ispc
 program instances execute in parallel on the hardware.")
     (home-page "https://github.com/ispc/ispc")
     (license license:bsd-3)))
+
+(define-public pcg-c
+  (let ((commit "83252d9c23df9c82ecb42210afed61a7b42402d7")
+        (revision "1"))
+    (package
+      (name "pcg-c")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/imneme/pcg-c")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "0768h0vw75a3smk39qsz1504v04a43s5w1ili1ijbixxv8gm42nf"))
+                (modules '((guix build utils)))
+                ;; Autogenerated files with some tests from test-high. If
+                ;; 128-bit integers are not supported, the build fails, but
+                ;; this is checked when building the tests.
+                (snippet #~(delete-file-recursively "sample"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+        #:test-target "test"
+        #:make-flags
+        #~(list
+           "CC=gcc"
+           (string-append "PREFIX=" #$output))
+        #:phases
+        #~(modify-phases %standard-phases
+            (delete 'configure)
+            (add-after 'unpack 'disable-sample
+              (lambda _
+                (substitute* "Makefile"
+                  ((".*cd sample.*") ""))))
+            (add-after 'unpack 'set-shared-library
+              (lambda _
+                (substitute* '("Makefile" "src/Makefile")
+                  (("\\.a") "\\.so")
+                  ((".*ar .*") "\t$(CC) $(CFLAGS) -o $@ $(LDFLAGS) -shared $^")
+                  ((".*ranlib.*") "")
+                  ((".*CFLAGS \\+=.*O3.*" orig)
+                   (string-append orig "CFLAGS += -fPIC\n")))))
+            (add-before 'install 'make-dirs
+              (lambda _
+                (mkdir-p (string-append #$output "/lib"))
+                (mkdir-p (string-append #$output "/include")))))))
+      (home-page "https://www.pcg-random.org")
+      (synopsis "C implementation of the PCG random generators")
+      (description "The Permuted Congruential Generator (PCG) extends the
+Linear Congruential Generator (LCG) with a permutation function to increase
+output randomness while retaining speed, simplicity, and conciseness.")
+      (license (list license:expat license:asl2.0))))) ; dual licensed