diff mbox series

[bug#74345,1/9] gnu: python-s3transfer: Update to 0.10.3.

Message ID 1c21604f8e3f1bc9784e17f32c140da3c746d0a8.1731518182.git.rekado@elephly.net
State New
Headers show
Series [bug#74345,1/9] gnu: python-s3transfer: Update to 0.10.3. | expand

Commit Message

Ricardo Wurmus Nov. 13, 2024, 5:16 p.m. UTC
* gnu/packages/python-web.scm (python-s3transfer): Update to 0.10.3.
[build-system]: Use pyproject-build-system.
[arguments]: Specify test-flags instead of replacing 'check phase.
[native-inputs]: Remove python-docutils, python-mock, and python-nose; add
python-pytest.
[propagated-inputs]: Remove python-urllib3.

Change-Id: Idd705b6968577c49f6b99adae40008f67bc3db23
---
 gnu/packages/python-web.scm | 23 ++++++++++-------------
 1 file changed, 10 insertions(+), 13 deletions(-)


base-commit: 07cd046c209f192032b425d2ee44f6025bff63a1
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7bbf05f3681..e93b32e3b1d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4718,27 +4718,24 @@  (define-public python-betamax-serializers
 (define-public python-s3transfer
   (package
     (name "python-s3transfer")
-    (version "0.5.0")
+    (version "0.10.3")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "s3transfer" version))
               (sha256
                (base32
-                "0k6sc956yrrv9b4laa0r79jhxajpyxr21jcd1ka8m1n53lz85vah"))))
-    (build-system python-build-system)
+                "032bjky1q8r5x80mvb0ah60g0zq4snwf0xa4c7779m44mdsfsl2g"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; Some of the 'integration' tests require network access or
-               ;; login credentials.
-               (invoke "nosetests" "--exclude=integration")))))))
+     (list
+      #:test-flags
+      ;; Some of the 'integration' tests require network access or
+      ;; login credentials.
+      '(list "--ignore-glob=tests/integration/*")))
     (native-inputs
-     (list python-docutils python-mock python-nose))
+     (list python-pytest))
     (propagated-inputs
-     (list python-botocore python-urllib3))
+     (list python-botocore))
     (synopsis "Amazon S3 Transfer Manager")
     (description "S3transfer is a Python library for managing Amazon S3
 transfers.")