[bug#76006,python-team] Add python-ebaysdk

Message ID 1c1de840-a83a-45d9-a1fe-be173844b973@riseup.net
State New
Headers
Series [bug#76006,python-team] Add python-ebaysdk |

Commit Message

Adriano Peluso Feb. 2, 2025, 11:03 a.m. UTC
  From 9dabb3a76c0e7a379b60f9638e934031260e9de4 Mon Sep 17 00:00:00 2001
Message-Id: <9dabb3a76c0e7a379b60f9638e934031260e9de4.1738493189.git.adriano_peluso@riseup.net>
From: Adriano Peluso <adriano_peluso@riseup.net>
Date: Sun, 2 Feb 2025 11:07:11 +0100
Subject: [PATCH 1/2] gnu: Add python-ebaysdk

  * gnu/packages/python-web.scm (python-ebaysdk): New variable

Change-Id: Ie840cfa13486dc44666f8ab6f29139d4fe413d06
---
 gnu/packages/python-web.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)


base-commit: a175b3d150f8fd25db4355c46a3fcae6fe097b77
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d17b61f29f..3df8aa4496 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1,4 +1,4 @@ 
-;;; GNU Guix --- Functional package management for GNU
+;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2015-2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
@@ -10671,3 +10671,29 @@  (define-public python-waybackpack
      "This package provides a library and a command-line tool that lets
 you download the entire Wayback Machine archive for a given URL.")
     (license license:expat)))
+
+(define-public python-ebaysdk
+  (package
+    (name "python-ebaysdk")
+    (version "2.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "ebaysdk" version))
+       (sha256
+        (base32 "1wy7m51h6sc4xz815kpr2il1krgpim9p8c6xm2fgb0dl0vbpbf1f"))))
+    (build-system pyproject-build-system)
+    ;;the tests
+    ;;  1) attempt to access the network
+    ;;  2) require ebay credentials to be written in a conf file
+    (arguments (list #:tests? #false))
+    (propagated-inputs (list python-lxml python-requests))
+    (native-inputs (list python-setuptools python-wheel))
+    (home-page "https://github.com/timotheus/ebaysdk-python")
+    (synopsis "The eBay SDK for Python")
+    (description "A programatic inteface into the eBay APIs.
+It simplifies development and cuts development time
+by standerizing calls, response processing, error handling, debugging
+across the Finding, Shopping, Merchandising, & Trading APIs.")
+    (license license:cddl1.0)))
+