diff mbox series

[bug#64560] gnu: Add emacs-gc-stats.

Message ID 1bfaec5aa1c5d8243aba15092866e7043add5c16.1689012599.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64560] gnu: Add emacs-gc-stats. | expand

Commit Message

Ahmad Draidi July 10, 2023, 6:09 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-gc-stats): New variable.
---
 gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: b7be0a999df8984fee8bd9d283b8fbe7e4da879d
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index fb36d7d29d..365721ffb4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3704,6 +3704,30 @@  (define-public emacs-aggressive-indent
 than @code{electric-indent-mode}.")
     (license license:gpl2+)))
 
+(define-public emacs-gc-stats
+  (package
+    (name "emacs-gc-stats")
+    (version "1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/"
+                                  "emacs-gc-stats-" version ".tar"))
+              (sha256
+               (base32
+                "19195s2nw87nmdz861j6shw5m2lv0spbcb1wff0y338fgx9sicgz"))))
+    (build-system emacs-build-system)
+    (home-page "https://git.sr.ht/~yantar92/emacs-gc-stats")
+    (synopsis "Collect Emacs GC statistics")
+    (description
+     "This package collects Emacs @dfn{garbage collection} (GC) statistics over
+time and saves it in the format that can be shared with Emacs maintainers.
+
+This package does not upload anything automatically.  You will need to upload
+the data manually, by sending email attachment.  If necessary, you can review
+@code{emacs-gc-stats-file} (defaults to @code{~/.emacs.d/emacs-gc-stats.eld})
+before uploading-it is just a text file.")
+    (license license:gpl3+)))
+
 (define-public emacs-gcmh
   ;; No tagged release upstream, but the commit below correspond to the 0.2.1
   ;; release.