diff mbox series

[bug#64657] gnu: Add emacs-mu4e-dashboard.

Message ID 1bedba277c7928d314064110627f5beb32f72069.1689487826.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64657] gnu: Add emacs-mu4e-dashboard. | expand

Commit Message

Ahmad Draidi July 16, 2023, 6:10 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: d08bd19de0b06d5da7f2c06fb733e245b566dd54

Comments

Liliana Marie Prikler July 16, 2023, 7:37 a.m. UTC | #1
Am Sonntag, dem 16.07.2023 um 10:10 +0400 schrieb Ahmad Draidi:
> * gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New variable.
> ---
>  gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 480096fb50..39e16da4cc 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -26203,6 +26203,33 @@ (define-public emacs-mu4e-conversation
>  maps the thread tree.")
>        (license license:gpl3+))))
>  
> +;; Package has no releases or tags.  Version is extracted from
> "Version:"
> +;; keyword in main file.
> +(define-public emacs-mu4e-dashboard
> +  (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
> +        (revision "0"))
> +    (package
> +      (name "emacs-mu4e-dashboard")
> +      (version (git-version "0.1.1" revision commit))
> +      (source (origin
> +                (method git-fetch)
> +                (file-name (git-file-name name version))
> +                (uri (git-reference
> +                      (url
> "https://github.com/rougier/mu4e-dashboard")
> +                      (commit commit)))
> +                (sha256
> +                 (base32
> +                 
> "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
Please put the file-name below the uri next time.  Also, I see you
submitting quite a number of patches for emacs packages; if possible,
try to make topical series so that they can be reviewed in one go.

Cheers
A July 16, 2023, 8:56 a.m. UTC | #2
Hello,

On 7/16/23 11:37, Liliana Marie Prikler wrote:
> Am Sonntag, dem 16.07.2023 um 10:10 +0400 schrieb Ahmad Draidi:
>> * gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New variable.
>> ---
>>   gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
>>   1 file changed, 27 insertions(+)
>>
>> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
>> index 480096fb50..39e16da4cc 100644
>> --- a/gnu/packages/emacs-xyz.scm
>> +++ b/gnu/packages/emacs-xyz.scm
>> @@ -26203,6 +26203,33 @@ (define-public emacs-mu4e-conversation
>>   maps the thread tree.")
>>         (license license:gpl3+))))
>>   
>> +;; Package has no releases or tags.  Version is extracted from
>> "Version:"
>> +;; keyword in main file.
>> +(define-public emacs-mu4e-dashboard
>> +  (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
>> +        (revision "0"))
>> +    (package
>> +      (name "emacs-mu4e-dashboard")
>> +      (version (git-version "0.1.1" revision commit))
>> +      (source (origin
>> +                (method git-fetch)
>> +                (file-name (git-file-name name version))
>> +                (uri (git-reference
>> +                      (url
>> "https://github.com/rougier/mu4e-dashboard")
>> +                      (commit commit)))
>> +                (sha256
>> +                 (base32
>> +
>> "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
> Please put the file-name below the uri next time.  Also, I see you
> submitting quite a number of patches for emacs packages; if possible,
> try to make topical series so that they can be reviewed in one go.

Noted.

Should I resend this and a couple of other patches I submitted with the 
file-name position change?

>
> Cheers
Liliana Marie Prikler July 16, 2023, 10:56 a.m. UTC | #3
Am Sonntag, dem 16.07.2023 um 12:56 +0400 schrieb A:
> Hello,
> 
> On 7/16/23 11:37, Liliana Marie Prikler wrote:
> > Am Sonntag, dem 16.07.2023 um 10:10 +0400 schrieb Ahmad Draidi:
> > > * gnu/packages/emacs-xyz.scm (emacs-mu4e-dashboard): New
> > > variable.
> > > ---
> > >   gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
> > >   1 file changed, 27 insertions(+)
> > > 
> > > diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-
> > > xyz.scm
> > > index 480096fb50..39e16da4cc 100644
> > > --- a/gnu/packages/emacs-xyz.scm
> > > +++ b/gnu/packages/emacs-xyz.scm
> > > @@ -26203,6 +26203,33 @@ (define-public emacs-mu4e-conversation
> > >   maps the thread tree.")
> > >         (license license:gpl3+))))
> > >   
> > > +;; Package has no releases or tags.  Version is extracted from
> > > "Version:"
> > > +;; keyword in main file.
> > > +(define-public emacs-mu4e-dashboard
> > > +  (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
> > > +        (revision "0"))
> > > +    (package
> > > +      (name "emacs-mu4e-dashboard")
> > > +      (version (git-version "0.1.1" revision commit))
> > > +      (source (origin
> > > +                (method git-fetch)
> > > +                (file-name (git-file-name name version))
> > > +                (uri (git-reference
> > > +                      (url
> > > "https://github.com/rougier/mu4e-dashboard")
> > > +                      (commit commit)))
> > > +                (sha256
> > > +                 (base32
> > > +
> > > "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
> > Please put the file-name below the uri next time.  Also, I see you
> > submitting quite a number of patches for emacs packages; if
> > possible,
> > try to make topical series so that they can be reviewed in one go.
> 
> Noted.
> 
> Should I resend this and a couple of other patches I submitted with
> the file-name position change?
I already fixed them locally, they should go live next Sunday.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..39e16da4cc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26203,6 +26203,33 @@  (define-public emacs-mu4e-conversation
 maps the thread tree.")
       (license license:gpl3+))))
 
+;; Package has no releases or tags.  Version is extracted from "Version:"
+;; keyword in main file.
+(define-public emacs-mu4e-dashboard
+  (let ((commit "16ffbb2a36817647e345f60acdfaac66dda28c0f")
+        (revision "0"))
+    (package
+      (name "emacs-mu4e-dashboard")
+      (version (git-version "0.1.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (file-name (git-file-name name version))
+                (uri (git-reference
+                      (url "https://github.com/rougier/mu4e-dashboard")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1fp2f9rvh20r3advbzcgm5vv2dzcyvy1618hfykbm6ac4wjscdll"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list mu))
+      (home-page "https://github.com/rougier/mu4e-dashboard")
+      (synopsis "Build your own dashboard for mu4e using org-mode")
+      (description
+       "This package provides an @code{org-mode} link type that allows
+execution of various @code{mu4e} queries when clicked.  Such links can be
+organized into a dashboard, by simply writing an org file.")
+      (license license:gpl3+))))
+
 (define-public emacs-pinentry
   (let ((commit "dcc9ba03252ee5d39e03bba31b420e0708c3ba0c")
         (revision "1"))