diff mbox series

[bug#72835,qt-team,v2,36/74] gnu: python-pyqt-builder: Update to 1.16.4.

Message ID 1be45fe77cf752cae5e91e2a57cc2998b4396d66.1726567073.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series update qt{5,6}. | expand

Commit Message

Z572 Sept. 18, 2024, 1:43 a.m. UTC
* gnu/packages/qt.scm (python-pyqt-builder): Update to 1.16.4.
[source]: Adjust pypi-url's name.
[build-system]: Switch to pyproject-build-system.
[native-inputs]: Add python-setuptools, python-setuptools-scm-next, and python-wheel.
[arguments]: Disable tests.

Change-Id: I2d1186536e9afb02de68c9fcb5e53d40eafa2ca0
---
 gnu/packages/qt.scm | 40 ++++++++++++++++++++++------------------
 1 file changed, 22 insertions(+), 18 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index bb7efcf3c0..4b87275a54 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4246,26 +4246,30 @@  (define-public python-pyqtwebengine-6
 
 (define-public python-pyqt-builder
   (package
-   (name "python-pyqt-builder")
-   (version "1.14.1")
-   (source
-    (origin
-     (method url-fetch)
-     (uri (pypi-uri "PyQt-builder" version))
-     (sha256
-      (base32
-       "00m5piryz9l4hp5z1ncaqicsp29kj71akdh4b10432zz18q3xg43"))))
-   (build-system python-build-system)
-   (inputs
-    (list python-sip))
-   (home-page "https://www.riverbankcomputing.com/static/Docs/PyQt-builder/")
-   (synopsis "PEP 517 compliant PyQt build system")
-   (description "PyQt-builder is a tool for generating Python bindings for C++
+    (name "python-pyqt-builder")
+    (version "1.16.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pyqt_builder" version))
+       (sha256
+        (base32
+         "1pxgcqk9qf0qvszllb467v2cmr6ngksfr2caz1a2xgkrwcdf85a5"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools
+                         python-setuptools-scm-next
+                         python-wheel))
+    (inputs
+     (list python-sip))
+    (arguments (list #:tests? #f))      ; no test suite
+    (home-page "https://www.riverbankcomputing.com/static/Docs/PyQt-builder/")
+    (synopsis "PEP 517 compliant PyQt build system")
+    (description "PyQt-builder is a tool for generating Python bindings for C++
 libraries that use the Qt application framework.  The bindings are built on
 top of the PyQt bindings for Qt.  PyQt-builder is used to build PyQt itself.")
-   ;; Either version 2 or 3, but no other version. See the file
-   ;; 'pyqtbuild/builder.py' in the source distribution for more information.
-   (license (list license:gpl2 license:gpl3))))
+    ;; Either version 2 or 3, but no other version. See the file
+    ;; 'pyqtbuild/builder.py' in the source distribution for more information.
+    (license (list license:gpl2 license:gpl3))))
 
 (define-public python-qtpy
   (package