diff mbox series

[bug#56007] gnu: lxd: Add ‘attr’ to inputs and use it in wrapper.

Message ID 1bda502e30333f03574eaf0ece31c419ec782221.1655351647.git.bjc@spork.org
State Accepted
Headers show
Series [bug#56007] gnu: lxd: Add ‘attr’ to inputs and use it in wrapper. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brian Cully June 16, 2022, 3:54 a.m. UTC
Fixes issue with lxd crashing on startup with:

  Error: exec: "setfattr": executable file not found in $PATH
---
 gnu/packages/virtualization.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès June 19, 2022, 9:04 p.m. UTC | #1
Hi,

Brian Cully <bjc@spork.org> skribis:

> Fixes issue with lxd crashing on startup with:
>
>   Error: exec: "setfattr": executable file not found in $PATH

I added a ChangeLog-style commit log and committed it.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index a7e1ccd6ca..015c291ec3 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1221,7 +1221,7 @@  (define-public lxd
                             '()
                             '("bash" "acl" "rsync" "tar" "xz" "btrfs-progs"
                               "gzip" "dnsmasq" "squashfs-tools" "iproute2"
-                              "criu" "iptables"))))
+                              "criu" "iptables" "attr"))))
                  ;; Remove unwanted binaries.
                  (for-each (lambda (prog)
                              (delete-file (string-append bin-dir prog)))
@@ -1247,6 +1247,7 @@  (define-public lxd
        ("libcap" ,libcap)
        ("lxc" ,lxc)
        ;; Run-time dependencies.
+       ("attr" ,attr)
        ("bash" ,bash-minimal)
        ("rsync" ,rsync)
        ("tar" ,tar)