diff mbox series

[bug#43781] (no subject)

Message ID 1bca958a-8333-3097-daf9-b587991a3217@mailbox.org
State Accepted
Headers show
Series [bug#43781] (no subject) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Tomás Ortín Nov. 26, 2020, 8:56 a.m. UTC
Here is the updated patch, sorry for the (long) delay. I've removed the patch and enabled the
tests, as I didn't know / understand I had disabled them.

Tomás


* gnu/packages/games.scm (cgoban): New variable.
---
1 file changed, 29 insertions(+)
gnu/packages/games.scm | 29 +++++++++++++++++++++++++++++

Comments

Efraim Flashner Nov. 29, 2020, 7:19 p.m. UTC | #1
I tweaked the source URI to use the sourceforge mirror scheme, organized
the inputs alphabetically and touched up the description to use @item
instead of dashes.

Patch pushed! Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d01d4de33a..2587c444ff 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -55,6 +55,7 @@ 
 ;;; Copyright © 2020 Trevor Hass <thass@okstate.edu>
 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2020 Lu hux <luhux@outlook.com>
+;;; Copyright © 2020 Tomás Ortín Fernández <tomasortin@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11919,6 +11920,34 @@  computer opponents or against real players online.")
 inside the Zenith Colony.")
     (license license:gpl3+)))
 
+(define-public cgoban
+  (package
+    (name "cgoban")
+    (version "1.9.14")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://sourceforge.net/projects/cgoban1/files/"
+                           "cgoban1/1.9.14/cgoban-1.9.14.tar.gz"))
+       (sha256
+        (base32 "0qlvkiaglqq0izfph3l04mp4rqqqm9ks6rcsrmzrggw9x706z2iv"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #t
+       #:phases %standard-phases))
+    (inputs
+     `(("xorgproto" ,xorgproto)
+       ("libx11" ,libx11)
+       ("libxt" ,libxt)))
+    (home-page "http://cgoban1.sourceforge.net/")
+    (synopsis "Go client for X11")
+    (description "Provides a large set of Go-related services for X11:
+-Local games with precise implementation of the Chinese and Japanese rulesets
+-Edition and visualization of SGF files-Connection to the NNGS or IGS Go servers
+-Bridge to Go modem protocol, allowing to play against Go modem-capable AIs
+such as GnuGo")
+    (license license:gpl2+)))
+
 (define-public paperview
   (let ((commit "9f8538eb6734c76877b878b8f1e52587f2ae19e6")
         (revision "1"))