[bug#78188,v2] gnu: kwallet-pam: Fix socat not in 'libexec/pam_kwallet_init' wrapper path.

Message ID 1b8f1e2c24fb227d77a4617635842fb16db5d7f0.1746122107.git.sergio.pastorperez@gmail.com
State New
Headers
Series [bug#78188,v2] gnu: kwallet-pam: Fix socat not in 'libexec/pam_kwallet_init' wrapper path. |

Commit Message

Sergio Pastor Pérez May 1, 2025, 5:55 p.m. UTC
  * gnu/packages/kde-plasma.scm (kwallet-pam)[phase]: Wrapper phase not setting
PATH variable to access 'socat' input.

Change-Id: I6e7a421af3dbbc844e319b7852246c89d979609c
---
 gnu/packages/kde-plasma.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)


base-commit: 881d46eb386c2de8bc6f1405972ee1e115eeb3a1
  

Comments

Zheng Junjie May 1, 2025, 6:17 p.m. UTC | #1
Sergio Pastor Pérez <sergio.pastorperez@gmail.com> writes:

> * gnu/packages/kde-plasma.scm (kwallet-pam)[phase]: Wrapper phase not setting
> PATH variable to access 'socat' input.
>
> Change-Id: I6e7a421af3dbbc844e319b7852246c89d979609c
> ---
>  gnu/packages/kde-plasma.scm | 10 +++++++++-
>  1 file changed, 9 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
> index 679a68cef6..400296f5da 100644
> --- a/gnu/packages/kde-plasma.scm
> +++ b/gnu/packages/kde-plasma.scm
> @@ -1305,7 +1305,15 @@ (define-public kwallet-pam
>      (arguments
>       (list
>        #:qtbase qtbase
> -      #:tests? #f)) ;no tests
> +      #:tests? #f ;no tests
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'install 'fix-socat-path
> +            (lambda* _
> +              (substitute* (string-append #$output
> +                                          "/libexec/pam_kwallet_init")
> +                (("socat")
> +                 (string-append #$socat "/bin/socat"))))))))

should

#~(modify-phases
   (add-after 'unpack 'fix-socat-path
    (lambda* (#:key inputs #:allow-other-keys)
      (substitute* "pam_kwallet_init"
         (("socat") (search-input-file inputs "bin/socat"))))))

>      (native-inputs (list extra-cmake-modules pkg-config))
>      (inputs (list linux-pam kwallet libgcrypt socat))
>      (synopsis "PAM Integration with KWallet")
>
> base-commit: 881d46eb386c2de8bc6f1405972ee1e115eeb3a1
  

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 679a68cef6..400296f5da 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1305,7 +1305,15 @@  (define-public kwallet-pam
     (arguments
      (list
       #:qtbase qtbase
-      #:tests? #f)) ;no tests
+      #:tests? #f ;no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'install 'fix-socat-path
+            (lambda* _
+              (substitute* (string-append #$output
+                                          "/libexec/pam_kwallet_init")
+                (("socat")
+                 (string-append #$socat "/bin/socat"))))))))
     (native-inputs (list extra-cmake-modules pkg-config))
     (inputs (list linux-pam kwallet libgcrypt socat))
     (synopsis "PAM Integration with KWallet")