diff mbox series

[bug#61118] gnu: Add emacs-lingva.

Message ID 1b56753a51b8956e016344b68ed8d15cf82b2b71.1674908263.git.csantosb@inventati.org
State New
Headers show
Series [bug#61118] gnu: Add emacs-lingva. | expand

Commit Message

Cayetano Santos Jan. 28, 2023, 12:17 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-lingva): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 37fdb382dad47149d8f5be41af108478800e9d30
--
2.39.1

Comments

Nicolas Goaziou Jan. 29, 2023, 2:42 p.m. UTC | #1
Hello,

Cayetano Santos via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-lingva): New variable.

Thank you. I applied it with the minor changes below.

> +(define-public emacs-lingva
> +  (let ((version "0.2")
> +        (revision "1")
> +        (commit "6c33594068fa33de622172503deeec6778d9c744"))

We usually hard-code version in `git-version' call below, so I removed
the version binding here.

> +    (package
> +      (name "emacs-lingva")
> +      (version
> +       (git-version version revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri
> +          (git-reference
> +           (url "https://codeberg.org/martianh/lingva.el")
> +           (commit commit)))
> +         (file-name
> +          (git-file-name name version))
> +         (sha256
> +          (base32
> +           "0r2f4wrd2v67m7198z0194pg853hbq4vvpd3x96y5ikbypywf426"))))
> +      (build-system emacs-build-system)
> +      (home-page "https://codeberg.org/martianh/lingva.el")
> +      (synopsis "Interact with the lingva.ml API from within Emacs")
> +      (description "This is a basic interface to the lingva.ml API, which allows you to obtain translations of texts from Google Translate without any tracking.")

I filled the description to make it fit under 80 characters.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 59a03f5db1..d43da2e32e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -24367,6 +24367,32 @@  (define-public emacs-google-translate
 on-line service.")
     (license license:gpl3+)))
 
+(define-public emacs-lingva
+  (let ((version "0.2")
+        (revision "1")
+        (commit "6c33594068fa33de622172503deeec6778d9c744"))
+    (package
+      (name "emacs-lingva")
+      (version
+       (git-version version revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://codeberg.org/martianh/lingva.el")
+           (commit commit)))
+         (file-name
+          (git-file-name name version))
+         (sha256
+          (base32
+           "0r2f4wrd2v67m7198z0194pg853hbq4vvpd3x96y5ikbypywf426"))))
+      (build-system emacs-build-system)
+      (home-page "https://codeberg.org/martianh/lingva.el")
+      (synopsis "Interact with the lingva.ml API from within Emacs")
+      (description "This is a basic interface to the lingva.ml API, which allows you to obtain translations of texts from Google Translate without any tracking.")
+      (license license:gpl3+))))
+
 (define-public emacs-helm-company
   (package
     (name "emacs-helm-company")