diff mbox series

[bug#64305] gnu: uwufetch: Add and use missing inputs.

Message ID 1b44a2db770f4f2a956c2235ea9cba3f0d1383a9.1691635036.git.juli@incana.org
State New
Headers show
Series [bug#64305] gnu: uwufetch: Add and use missing inputs. | expand

Commit Message

Juliana Sims Aug. 10, 2023, 2:37 a.m. UTC
Hi there,

Oops! I sent that last email wrong!

For Ludovic: this is the same as that other email, but I want to make sure
everything is threaded and catalogued properly.

For everyone else: this patch takes Ludovic's advice and substitutes references
to "grep" and "awk" in the uwufetch source code with references to the
fully-qualified paths of those binaries. It adds them as regular inputs rather
than the propagated inputs the previous version of this patch added them as.

Thanks,
Juli

* gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs.
[phases]: Use the fully-qualified paths of the input gawk and grep.
---
 gnu/packages/admin.scm | 7 +++++++
 1 file changed, 7 insertions(+)


base-commit: 90e34d25d5e7c14b7f3293a78f3cdad676c0d035

Comments

Ludovic Courtès Aug. 12, 2023, 8:36 p.m. UTC | #1
Hi,

Juliana Sims <juli@incana.org> skribis:

> Hi there,
>
> Oops! I sent that last email wrong!
>
> For Ludovic: this is the same as that other email, but I want to make sure
> everything is threaded and catalogued properly.
>
> For everyone else: this patch takes Ludovic's advice and substitutes references
> to "grep" and "awk" in the uwufetch source code with references to the
> fully-qualified paths of those binaries. It adds them as regular inputs rather
> than the propagated inputs the previous version of this patch added them as.
>
> Thanks,
> Juli
>
> * gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs.
> [phases]: Use the fully-qualified paths of the input gawk and grep.

Perfect, thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 33f9b703a7..6b6b05c4a0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4025,6 +4025,11 @@  (define-public uwufetch
           (delete 'configure)
           (add-before 'build 'patch-source-paths
             (lambda _
+              (substitute* "fetch.c"
+                (("grep")
+                 #$(file-append grep "/bin/grep"))
+                (("awk")
+                 #$(file-append gawk "/bin/awk")))
               (substitute* "uwufetch.c"
                 (("(/usr(/local)?)(.*;)" all _ _ rest)
                  (string-append #$output rest)))))
@@ -4033,6 +4038,8 @@  (define-public uwufetch
             (lambda _
               (mkdir-p (string-append #$output "/include")))))))
     (inputs (list lshw
+                  gawk
+                  grep
                   ;; viu XXX not yet packaged in Guix
                   xwininfo))
     (home-page "https://github.com/TheDarkBug/uwufetch")