diff mbox series

[bug#65189] gnu: uwufetch: Add and use missing inputs.

Message ID 1b44a2db770f4f2a956c2235ea9cba3f0d1383a9.1691630423.git.juli@incana.org
State New
Headers show
Series [bug#65189] gnu: uwufetch: Add and use missing inputs. | expand

Commit Message

Juliana Sims Aug. 10, 2023, 1:20 a.m. UTC
Hi Ludovic,

Putting the fully-qualified paths of binaries into the source like this had not
occurred to me before, but it seems so obviously correct now. Thanks for
suggesting it! This patch uses that technique; I'll be adding it to my bag of
packaging tricks for the future as well :)

Thanks,
Juli

* gnu/packages/admin.scm (uwufetch) [inputs]: Add missing inputs.
[phases]: Use the fully-qualified paths of the input gawk and grep.
---
 gnu/packages/admin.scm | 7 +++++++
 1 file changed, 7 insertions(+)


base-commit: 90e34d25d5e7c14b7f3293a78f3cdad676c0d035

Comments

Juliana Sims Aug. 10, 2023, 2:34 a.m. UTC | #1
i done did a bad and sent the email wrong :(
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 33f9b703a7..6b6b05c4a0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4025,6 +4025,11 @@  (define-public uwufetch
           (delete 'configure)
           (add-before 'build 'patch-source-paths
             (lambda _
+              (substitute* "fetch.c"
+                (("grep")
+                 #$(file-append grep "/bin/grep"))
+                (("awk")
+                 #$(file-append gawk "/bin/awk")))
               (substitute* "uwufetch.c"
                 (("(/usr(/local)?)(.*;)" all _ _ rest)
                  (string-append #$output rest)))))
@@ -4033,6 +4038,8 @@  (define-public uwufetch
             (lambda _
               (mkdir-p (string-append #$output "/include")))))))
     (inputs (list lshw
+                  gawk
+                  grep
                   ;; viu XXX not yet packaged in Guix
                   xwininfo))
     (home-page "https://github.com/TheDarkBug/uwufetch")