diff mbox series

[bug#60824,v2,1/2] gnu: perl-xml-xpath: Wrap xpath command.

Message ID 1b22f02d1d3237a361262b9fcc8ecbf43e935c20.1684431164.git.mirai@makinata.eu
State New
Headers show
Series [bug#60824,v2,1/2] gnu: perl-xml-xpath: Wrap xpath command. | expand

Commit Message

Bruno Victal May 18, 2023, 5:33 p.m. UTC
* gnu/packages/xml.scm (perl-xml-xpath)[arguments]: Wrap xpath.
[description]: Document xpath command presence.
---
 gnu/packages/xml.scm | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)


base-commit: 5b700945fb0b33eec410de8979cae2fbf0d4f118
diff mbox series

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 2bc4f66c01..3c94937f49 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 David Larsson <david.larsson@selfhosted.xyz>
 ;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1044,6 +1045,16 @@  (define-public perl-xml-xpath
                (base32
                 "03yxj7w5a43ibbpiqsvb3lswj2b71dydsx4rs2fw0p8n0l3i3j8w"))))
     (build-system perl-build-system)
+    (arguments
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'wrap 'wrap-xpath
+            (lambda _
+              (wrap-program (string-append #$output "/bin/xpath")
+                `("PERL5LIB" ":" prefix
+                  ,(cons (string-append #$output "/lib/perl5/site_perl")
+                         (string-split (getenv "PERL5LIB") #\:)))))))))
     (native-inputs
      (list perl-path-tiny))
     (propagated-inputs
@@ -1053,7 +1064,7 @@  (define-public perl-xml-xpath
     (description
      "This module aims to comply exactly to the @url{XPath specification,
 https://www.w3.org/TR/xpath} and yet allow extensions to be added in
-the form of functions.")
+the form of functions.  It also provides the command @command{xpath}.")
     (license license:perl-license)))
 
 (define-public pugixml