@@ -3309,20 +3309,15 @@ (define-public git-annex-remote-rclone
(define-public fossil
(package
(name "fossil")
- (version "2.23")
+ (version "2.25")
(source
(origin
(method url-fetch)
(uri (string-append
- "https://www.fossil-scm.org/home/tarball/"
- "47362306a7dd7c6fc3cab77cebe5d25469b0a9448479d9718eb5c49c8337b29"
- "/fossil-src-" version ".tar.gz"))
- ;; XXX: Currently the above hash must be manually updated.
+ "https://fossil-scm.org/home/tarball/version-" version
+ "/fossil-" version ".tar.gz"))
(sha256
- (base32 "1r1kabvmlhc0qgyq8g9zhq8i0123x9dba9b71j4xc71k14kfqjm9"))
- (modules '((guix build utils)))
- (snippet
- '(delete-file-recursively "compat"))))
+ (base32 "18gws90by2q6a6rk7h3mx46pn79lz4zi3saxlyrdz5982mw9rvp4"))))
(build-system gnu-build-system)
(native-inputs
(list tcl ;for configuration only
@@ -3333,6 +3328,7 @@ (define-public fossil
(list openssl zlib sqlite-next))
(arguments
`(#:configure-flags (list "--with-openssl=auto"
+ "--enable-json"
"--disable-internal-sqlite")
#:test-target "test"
#:phases (modify-phases %standard-phases
From: Ashish SHUKLA <ashish.is@lostca.se> * gnu/packages/version-control.scm (fossil): Update to 2.25. [source]: switch to a simpler tarball URL. [arguments]<configure-flags>: Add flag to enable JSON support. Change-Id: I644dff44ce96d7f42e92cdbc994c4096ac55bf10 --- gnu/packages/version-control.scm | 14 +++++--------- 1 file changed, 5 insertions(+), 9 deletions(-) base-commit: 4473f8ae902c2192cab6919363a9101ce9861e45