diff mbox series

[bug#61675,2/2] gnu: Add latino.

Message ID 1ad50ca0-c218-d602-3026-5c2441105b5f@disroot.org
State New
Headers show
Series None | expand

Commit Message

Adam Faiz Feb. 21, 2023, 1:46 p.m. UTC
From cb275653fdd7bb8562708e7865a0be8d903998d6 Mon Sep 17 00:00:00 2001
Message-Id: 
<cb275653fdd7bb8562708e7865a0be8d903998d6.1676986321.git.adam.faiz@disroot.org>
In-Reply-To: 
<8739b1b5d6eb9de504d7799e22efd7996acfac83.1676986321.git.adam.faiz@disroot.org>
References: 
<8739b1b5d6eb9de504d7799e22efd7996acfac83.1676986321.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Tue, 21 Feb 2023 17:06:04 +0800
Subject: [PATCH 2/2] gnu: Add latino.

* gnu/packages/latino.scm: New file.
---
  gnu/packages/latino.scm | 66 +++++++++++++++++++++++++++++++++++++++++
  1 file changed, 66 insertions(+)
  create mode 100644 gnu/packages/latino.scm
diff mbox series

Patch

diff --git a/gnu/packages/latino.scm b/gnu/packages/latino.scm
new file mode 100644
index 0000000000..ae12702b8a
--- /dev/null
+++ b/gnu/packages/latino.scm
@@ -0,0 +1,66 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Adam Faiz <adam.faiz@disroot.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages latino)
+  #:use-module (guix build-system cmake)
+  #:use-module (guix git-download)
+  #:use-module (guix gexp)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses)
+                #:prefix license:)
+  #:use-module (gnu packages readline)
+  #:use-module (gnu packages shells))
+
+(define-public latino
+  (let ((commit "c9ba798aeebd733c0986eced78021394b2d87d4c")
+        (revision "0"))
+  (package
+    (name "latino")
+    (version (git-version "1.4.3" revision commit))
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/lenguaje-latino/latino-core")
+         (commit commit)))
+       (file-name
+        (git-file-name name version))
+       (sha256
+        (base32 "1pmplp32i5c546mcij9cks3lgqysz1bixy8ll4v9bb8c3f5pmaa1"))
+       (modules '((guix build utils)))
+       (snippet
+        #~(begin
+            ; Unbundle linenoise
+            (for-each delete-file-recursively
+                      '("src/lib" "src/linenoise"))
+            (substitute* "src/CMakeLists.txt"
+              ((".*linenoise.*") "")
+              (("latuilib.c") "latuilib.c)")
+              (("link_libraries.m.")
+               (string-append "link_libraries(m)\n"
+                              "    link_libraries(linenoise)")))))))
+    (build-system cmake-build-system)
+    (inputs
+     (list linenoise readline))
+    (synopsis "Programming language with Spanish syntax")
+    (description
+     "Latino is a programming language with Spanish syntax,
+inspired by Lua and Python.")
+    (home-page "https://www.lenguajelatino.org")
+    (license license:gpl3+))))