diff mbox series

[bug#57780,2/2] gnu: xsimd-benchmark: Build example.

Message ID 1ac1d30c696807ac8a5481cf0fa2a2931e00974a.1663082562.git.code@greghogan.com
State Accepted
Headers show
Series Update xsimd. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Sept. 13, 2022, 8:26 p.m. UTC
* gnu/packages/cpp.scm (xsimd-benchmark): Fix package name.
[arguments]<#:configure-flags>: Enable examples ...
<#:phases>{install} ... and install.
---
 gnu/packages/cpp.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 8aea2e2441..6289c9520f 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -456,12 +456,12 @@  (define-public google-highway
 library for SIMD (Single Instruction, Multiple Data) with runtime dispatch.")
     (license license:asl2.0)))
 
-(define-public xsmimd-benchmark
+(define-public xsimd-benchmark
   (package
     (inherit xsimd)
     (name "xsimd-benchmark")
     (arguments
-     `(#:configure-flags (list "-DBUILD_BENCHMARK=ON")
+     `(#:configure-flags (list "-DBUILD_BENCHMARK=ON" "-DBUILD_EXAMPLES=ON")
        #:tests? #f
        #:phases (modify-phases %standard-phases
                   (add-after 'unpack 'remove-march=native
@@ -470,9 +470,11 @@  (define-public xsmimd-benchmark
                         (("-march=native") ""))))
                   (replace 'install
                     (lambda* (#:key outputs #:allow-other-keys)
-                      ;; Install nothing but the executable.
+                      ;; Install nothing but the executables.
                       (let ((out (assoc-ref outputs "out")))
                         (install-file "benchmark/benchmark_xsimd"
+                                      (string-append out "/bin"))
+                        (install-file "examples/mandelbrot"
                                       (string-append out "/bin"))))))))
     (synopsis "Benchmark of the xsimd library")