diff mbox series

[bug#64224,v2] gnu: Add python-cloup.

Message ID 1a87b17d99ee76b1e8bc96d53f1d1eda21311447.1687443680.git.jgart@dismail.de
State New
Headers show
Series [bug#64224,v2] gnu: Add python-cloup. | expand

Commit Message

jgart June 22, 2023, 2:24 p.m. UTC
From: Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>

* gnu/packages/python-xyz.scm (python-cloup): New variable.

Co-authored-by: jgart <jgart@dismail.de>
---

Hi,

Thanks for the patch. Here is a v2 that simplifies the home-page
description a bit and removes the native-input of setuptools, since it
is not needed.

Lars,

Do you happen to know why pytest is still required here even though we
are using pyproject-build-system? Is there a thread you can point me to
that explains that? Not sure I understand why this is the case yet from
reading the code for that build-system.

all best,

jgart

 gnu/packages/python-xyz.scm | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)


base-commit: 8b6bc4b2aa579193306cdc7a28f788c9afb4e039
prerequisite-patch-id: b40ddb3f1c2f780c18f34b826b1229bb10358ec7
prerequisite-patch-id: 35ea140df746960cf9b020cb8abb74e6889b056c

Comments

Lars-Dominik Braun June 22, 2023, 7:32 p.m. UTC | #1
Hi jgart,

> Do you happen to know why pytest is still required here even though we
> are using pyproject-build-system? Is there a thread you can point me to
> that explains that? Not sure I understand why this is the case yet from
> reading the code for that build-system.

pytest is always required as an input when used for testing. It is never
pulled in automatically, but its presence decides which testing framework
will be used (i.e. pytest is present → use pytest).

Lars
Daniel Meißner June 23, 2023, 7:41 a.m. UTC | #2
Hi jgart,

jgart <jgart@dismail.de> writes:

> From: Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
>
> * gnu/packages/python-xyz.scm (python-cloup): New variable.
>
> Co-authored-by: jgart <jgart@dismail.de>
> ---
>
> Hi,
>
> Thanks for the patch. Here is a v2 that simplifies the home-page
> description a bit and removes the native-input of setuptools, since it
> is not needed.

Thanks for your v2.  Weirdly enough, I thought I had tested it without
setuptools and it did not work.  However, I tested it again and now it
works for me also.  Thanks for your improvements.  LGTM.

Best
jgart June 23, 2023, 2:20 p.m. UTC | #3
Cool, I'll push this later today after I finish work. I'd like to review it one more time.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b650b71f3b..5dcd6b9138 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -106,7 +106,7 @@ 
 ;;; Copyright © 2021 Franck Pérignon <franck.perignon@univ-grenoble-alpes.fr>
 ;;; Copyright © 2021, 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
-;;; Copyright © 2021 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
+;;; Copyright © 2021, 2022, 2023 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
 ;;; Copyright © 2021, 2022 Pradana Aumars <paumars@courrier.dev>
 ;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Sébastien Lerique <sl@eauchat.org>
@@ -4578,6 +4578,27 @@  (define-public python-cligj
 well-tested and interoperable CLIs for handling GeoJSON.")
     (license license:bsd-3)))
 
+(define-public python-cloup
+  (package
+    (name "python-cloup")
+    (version "2.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "cloup" version))
+              (sha256
+               (base32
+                "05c6cjpnf9s72gyn5dckxbmd8rf2kgdzfsl7pqzrnc1lcdl13zmv"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-click))
+    (native-inputs (list python-pytest))
+    (home-page "https://github.com/janLuke/cloup")
+    (synopsis "Extension library for python-click")
+    (description
+     "Cloup enriches Click with several features that make it more expressive
+and configurable such as option groups, constraints, subcommand aliases,
+subcommands sections and a themeable HelpFormatter.")
+    (license license:bsd-3)))
+
 (define-public python-vcversioner
   (package
     (name "python-vcversioner")