[bug#74821] gnu: cgit: Update to 1.2.3-7.751a5b5.

Message ID 1a8790d643cc3171d765ec483e99fe1e831747e5.1734003995.git.~@wolfsden.cz
State New
Headers
Series [bug#74821] gnu: cgit: Update to 1.2.3-7.751a5b5. |

Commit Message

Tomas Volf Dec. 12, 2024, 11:46 a.m. UTC
  * gnu/packages/version-control.scm (cgit): Update to 1.2.3-7.751a5b5.

Change-Id: I3f4d27246065d67a258a8cf3b3dea2e0b2d2bc9f
---
 gnu/packages/version-control.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)
  

Comments

Maxim Cournoyer Dec. 17, 2024, 1:24 a.m. UTC | #1
Hi Tomas,

Tomas Volf <~@wolfsden.cz> writes:

> * gnu/packages/version-control.scm (cgit): Update to 1.2.3-7.751a5b5.
>
> Change-Id: I3f4d27246065d67a258a8cf3b3dea2e0b2d2bc9f
> ---
>  gnu/packages/version-control.scm | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
> index 3339e79390..28afcfa2ff 100644
> --- a/gnu/packages/version-control.scm
> +++ b/gnu/packages/version-control.scm
> @@ -1345,8 +1345,8 @@ (define-public git-remote-gcrypt
>     (license license:gpl3+)))
>

Usually, we request that a comment is added to explain why a particular
unreleased commit must be used instead of the latest release.  Would it
be possible to remove the commit/rev variables and switch back to use
the latest release?  It's not clear why we aren't doing that.
  
Tomas Volf Dec. 18, 2024, 2:26 p.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hi Tomas,
>
> Tomas Volf <~@wolfsden.cz> writes:
>
>> * gnu/packages/version-control.scm (cgit): Update to 1.2.3-7.751a5b5.
>>
>> Change-Id: I3f4d27246065d67a258a8cf3b3dea2e0b2d2bc9f
>> ---
>>  gnu/packages/version-control.scm | 10 +++++-----
>>  1 file changed, 5 insertions(+), 5 deletions(-)
>>
>> diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
>> index 3339e79390..28afcfa2ff 100644
>> --- a/gnu/packages/version-control.scm
>> +++ b/gnu/packages/version-control.scm
>> @@ -1345,8 +1345,8 @@ (define-public git-remote-gcrypt
>>     (license license:gpl3+)))
>>
>
> Usually, we request that a comment is added to explain why a particular
> unreleased commit must be used instead of the latest release.

This was not requested 11 months back when I did the initial upgrade,
but fair enough.  Shall I send a separate patch adding the comment?

> Would it be possible to remove the commit/rev variables and switch
> back to use the latest release?  It's not clear why we aren't doing
> that.

Possible?  Sure.  Good idea?  Not in my opinion.  Last release is from 5
years ago, and there were many bug fixes since then.  Even sites like
git.kernel.org do not use the last release.

Have a nice day,
Tomas Volf
  
Maxim Cournoyer Dec. 19, 2024, 5:41 a.m. UTC | #3
Hi Tomas,

I've added a comment mentioning why we use the latest commit (no tagged
releases in 5 years) and pushed.
  

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3339e79390..28afcfa2ff 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1345,8 +1345,8 @@  (define-public git-remote-gcrypt
    (license license:gpl3+)))
 
 (define-public cgit
-  (let ((commit "2a13177f3dce660954b1ce78bc83338fe64f6b33")
-        (rev "6"))
+  (let ((commit "751a5b527de07dde30a69709c2d6fc6f05fafd06")
+        (rev "7"))
     (package
       (name "cgit")
       ;; Update the ‘git-source’ input as well.
@@ -1358,7 +1358,7 @@  (define-public cgit
                       (commit commit)))
                 (sha256
                  (base32
-                  "0g02rghwx6gda15ip1pd3rli6smis1mrcb904zlxfqmm6dlc7lca"))
+                  "0rfflh7fnfhchd7pdspn2r416c5kaya37cad918f7ldidzwvmp37"))
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (arguments
@@ -1434,9 +1434,9 @@  (define-public cgit
              (method url-fetch)
              ;; cgit is tightly bound to git.  Use GIT_VER from the Makefile,
              ;; which may not match the current (package-version git).
-             (uri "mirror://kernel.org/software/scm/git/git-2.46.2.tar.xz")
+             (uri "mirror://kernel.org/software/scm/git/git-2.47.1.tar.xz")
              (sha256
-              (base32 "18rcmvximgyg3v1a9papi9djfamiak0ys5cmgx7ll29nhp3a3s2y"))))
+              (base32 "046kdr5dhg31hjcg6wpfqnwwbaqdjyax7n8wx5s26fdf4fxzkn7k"))))
          ("bash-minimal" ,bash-minimal)
          ("openssl" ,openssl)
          ("python" ,python)