diff mbox series

[bug#49556,2/2] gnu: VDE 2: Update to 2.3.2-0.8599321.

Message ID 1a3710d2a7891dfb069d6d8dfadeca998954bc1e.1626217314.git.leo@famulari.name
State Accepted
Headers show
Series [bug#49556,1/2] gnu: Add wolfSSL. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Leo Famulari July 13, 2021, 11:01 p.m. UTC
Updating to this unreleased revision allows us to package VDE 2 with
wolfSSL instead of the obsolete OpenSSL 1.0:

https://github.com/virtualsquare/vde-2/issues/2

* gnu/packages/networking.scm (vde2): Update to 2.3.2-0.8599321.
[source]: Use git-fetch.
[native-inputs]: Add autoconf, automake, and libtool
[inputs]: Replace openssl-1.0 with wolfssl.
---
 gnu/packages/networking.scm | 23 ++++++++++++++++-------
 1 file changed, 16 insertions(+), 7 deletions(-)

Comments

Diego Nicola Barbato Aug. 3, 2021, 6:01 p.m. UTC | #1
Hi Leo,

Leo Famulari <leo@famulari.name> writes:

> Updating to this unreleased revision allows us to package VDE 2 with
> wolfSSL instead of the obsolete OpenSSL 1.0:
>
> https://github.com/virtualsquare/vde-2/issues/2
>
> * gnu/packages/networking.scm (vde2): Update to 2.3.2-0.8599321.
> [source]: Use git-fetch.
> [native-inputs]: Add autoconf, automake, and libtool
> [inputs]: Replace openssl-1.0 with wolfssl.

[...]

I've tried building this and it looks like the configure script fails to
detect wolfSSL (the build still succeeds, but "VDE CryptCab" is
disabled):

--8<---------------cut here---------------start------------->8---
Configure results:

 - VDE CryptCab............ disabled
 + VDE Router.............. enabled
 + VDE VXLAN............... enabled
 + Python Libraries........ enabled
 + TAP support............. enabled
 + pcap support............ enabled
 - Experimental features... disabled
 - Profiling options....... disabled
 - Kernel switch........... disabled


configure: WARNING: VDE CryptCab support has been disabled because wolfSSL is
not installed on your system, or because wolfssl/wolfcrypt/chacha.h could not be found.
Please install libwolfssl if you want CryptCab to be compiled and installed.
--8<---------------cut here---------------end--------------->8---

I suspect the following lines in configure.ac are the culprit:

--8<---------------cut here---------------start------------->8---
AC_CHECK_LIB([crypto], [EVP_EncryptInit],
  [add_cryptcab_support=yes],
  [add_cryptcab_support=no ; warn_cryptcab=yes])
--8<---------------cut here---------------end--------------->8---

This might've been overlooked when switching from OpenSSL to wolfSSL,
since libcrypto is provided by the former, but not the latter.  They
should probably be changed to something like this instead:

--8<---------------cut here---------------start------------->8---
AC_CHECK_LIB([wolfssl], [wc_Chacha_Process],
  [add_cryptcab_support=yes],
  [add_cryptcab_support=no ; warn_cryptcab=yes])
--8<---------------cut here---------------end--------------->8---

I'll report this issue upstream.

Regards,

Diego
Leo Famulari Aug. 3, 2021, 10:04 p.m. UTC | #2
On Tue, Aug 03, 2021 at 06:01:33PM +0000, Diego Nicola Barbato wrote:
> I suspect the following lines in configure.ac are the culprit:
> 
> --8<---------------cut here---------------start------------->8---
> AC_CHECK_LIB([crypto], [EVP_EncryptInit],
>   [add_cryptcab_support=yes],
>   [add_cryptcab_support=no ; warn_cryptcab=yes])
> --8<---------------cut here---------------end--------------->8---

Thanks for catching that!

> I'll report this issue upstream.

Okay, please share the link to your report once you have made it.
Diego Nicola Barbato Aug. 5, 2021, 3:37 p.m. UTC | #3
Hi Leo,

Leo Famulari <leo@famulari.name> writes:

> On Tue, Aug 03, 2021 at 06:01:33PM +0000, Diego Nicola Barbato wrote:
>> I suspect the following lines in configure.ac are the culprit:
>> 
>> --8<---------------cut here---------------start------------->8---
>> AC_CHECK_LIB([crypto], [EVP_EncryptInit],
>>   [add_cryptcab_support=yes],
>>   [add_cryptcab_support=no ; warn_cryptcab=yes])
>> --8<---------------cut here---------------end--------------->8---
>
> Thanks for catching that!
>
>> I'll report this issue upstream.
>
> Okay, please share the link to your report once you have made it.

I've submitted a pull request:
https://github.com/virtualsquare/vde-2/pull/27

Regards,

Diego
Leo Famulari Aug. 11, 2021, 7:47 p.m. UTC | #4
On Thu, Aug 05, 2021 at 03:37:47PM +0000, Diego Nicola Barbato wrote:
> Hi Leo,
> 
> Leo Famulari <leo@famulari.name> writes:
> 
> > On Tue, Aug 03, 2021 at 06:01:33PM +0000, Diego Nicola Barbato wrote:
> >> I suspect the following lines in configure.ac are the culprit:
> >> 
> >> --8<---------------cut here---------------start------------->8---
> >> AC_CHECK_LIB([crypto], [EVP_EncryptInit],
> >>   [add_cryptcab_support=yes],
> >>   [add_cryptcab_support=no ; warn_cryptcab=yes])
> >> --8<---------------cut here---------------end--------------->8---
> >
> > Thanks for catching that!
> >
> >> I'll report this issue upstream.
> >
> > Okay, please share the link to your report once you have made it.
> 
> I've submitted a pull request:
> https://github.com/virtualsquare/vde-2/pull/27

They accepted your patch.

I've added the wolfSSL package and updated VDE-2 to include your fix,
with commit e6388b48f3df21b792cd61f93fddc7274238bac6
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 19b58501e9..d99af3035c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -13,7 +13,7 @@ 
 ;;; Copyright © 2016 Benz Schenk <benz.schenk@uzh.ch>
 ;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017, 2020 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2017, 2020, 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2017, 2019 Gábor Boskovits <boskovits@gmail.com>
@@ -3789,22 +3789,31 @@  network.  This must be enabled on the target host, usually in the BIOS.")
     (license license:gpl2)))
 
 (define-public vde2
+  (let ((commit "8599321526d0a31925fe55cabbe132b752cb268a")
+        (revision "0"))
   (package
     (name "vde2")
-    (version "2.3.2")
+    (version (git-version "2.3.2" revision commit))
     (source
      (origin
-       (method url-fetch)
-       (uri "mirror://sourceforge/vde/vde2/2.3.2/vde2-2.3.2.tar.gz")
+       (method git-fetch)
+       (uri (git-reference
+              (url "https://github.com/virtualsquare/vde-2")
+              (commit commit)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "14xga0ib6p1wrv3hkl4sa89yzjxv7f1vfqaxsch87j6scdm59pr2"))))
+        (base32 "1dirkcbjh7c5kz7d065g1yq7vg8jl93hql3brfxd84k8hc8nqjb2"))))
     (build-system gnu-build-system)
     (arguments
      `(#:parallel-build? #f))           ; Build fails if #t.
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)))
     (inputs
      `(("python" ,python)
        ("libpcap" ,libpcap)
-       ("openssl" ,openssl-1.0)))       ; Build fails with 1.1.
+       ("wolfssl" ,wolfssl)))
     (home-page "https://github.com/virtualsquare/vde-2")
     (synopsis "Virtual Distributed Ethernet")
     (description "VDE is a set of programs to provide virtual software-defined
@@ -3816,7 +3825,7 @@  cables.")
                    license:lgpl2.1       ; libvdeplug
                    (license:non-copyleft ; slirpvde
                     "file://COPYING.slirpvde"
-                    "See COPYING.slirpvde in the distribution.")))))
+                    "See COPYING.slirpvde in the distribution."))))))
 
 (define-public haproxy
   (package