diff mbox series

[bug#72219,02/34] gnu: Add python-pytest-8.

Message ID 1a2de918836ed5b250461b38f8ed0ee22f7e64a9.1721514686.git.sharlatanus@gmail.com
State New
Headers show
Series Astronomy update 2024/07 | expand

Commit Message

Sharlatan Hellseher July 20, 2024, 10:40 p.m. UTC
* gnu/packages/check.scm (python-pytest-8): New variable.

Change-Id: Ie584a48a2749cc7b196e373fe4e6e08f47165620
---
 gnu/packages/check.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3bfcf5a37e..77e5bd6ef6 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1388,6 +1388,36 @@  (define-public python-pytest
 and many external plugins.")
     (license license:expat)))
 
+(define-public python-pytest-8
+  (package/inherit python-pytest
+    (name "python-pytest")
+    (version "8.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest" version))
+       (sha256
+        (base32 "0xvr25qvmdh6z03jpgg24adhgqkvkal2g2v8vk63j6909q8bhjyy"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:test-flags
+      #~(list "-k" (string-append
+                    "not test_code_highlight_continuation"
+                    " and not test_code_highlight"
+                    " and not test_code_highlight_custom_theme"
+                    " and not test_code_highlight_invalid_theme"
+                    " and not test_code_highlight_invalid_theme_mode"
+                    " and not test_code_highlight_simple"
+                    " and not test_color_yes"
+                    " and not test_comparisons_handle_colors"
+                    " and not test_empty_NO_COLOR_and_FORCE_COLOR_ignored"
+                    " and not test_remove_dir_prefix"))))
+    (propagated-inputs
+     (modify-inputs (package-propagated-inputs python-pytest)
+       (append python-exceptiongroup)
+       (replace "python-pluggy" python-pluggy-next)))))
+
 (define-public python-pytest-next
   (package/inherit python-pytest
     (name "python-pytest")