diff mbox series

[bug#66417,1/3] gnu: Add python-google-auth-oauthlib.

Message ID 1a28a8560b6f75172d66cbdc907994746cad46c2.1696777449.git.doc@evr.ist
State New
Headers show
Series Bump python-google-api-client to version 2 | expand

Commit Message

Pierre-Evariste Dagand Oct. 9, 2023, 7:40 a.m. UTC
* gnu/packages/python-web.scm (python-google-auth-oauthlib): New variable.
---
 gnu/packages/python-web.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d7fe634aba..0e52f2fdbd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5180,6 +5180,26 @@  (define-public python-google-auth-httplib2
 for httplib2 transport.")
     (license license:asl2.0)))
 
+(define-public python-google-auth-oauthlib
+  (package
+    (name "python-google-auth-oauthlib")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "google-auth-oauthlib" version))
+       (sha256
+        (base32 "1yvsjd1vh440nsh9vpnig23sq4k1ia749x5g1dwm7r4110xqrsl3"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-google-auth python-requests-oauthlib))
+    (native-inputs (list python-flask))
+    (home-page
+     "https://github.com/GoogleCloudPlatform/google-auth-library-python-oauthlib")
+    (synopsis "Google Authentication Library: oauthlib")
+    (description "This package provides a Google Authentication Library plugin
+with oauthlib.")
+    (license license:asl2.0)))
+
 (define-public whoogle-search
   (package
     (name "whoogle-search")