diff mbox series

[bug#48892] gnu: Add xkbset.

Message ID 1Oo7OajQcqoLl9HbqErlfz2VWbQKcgmcx-n1EbPyNJKXp5BH2j3mKNp42hVM4TCtWQ0IFL5eJbWkXi9N0rfaZg0aQuWeQgjxiuTGQp8of8g=@apatience.com
State Accepted
Headers show
Series [bug#48892] gnu: Add xkbset. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience June 9, 2021, 12:18 p.m. UTC
On Tuesday, June 8th, 2021 at 17:23, Ludovic Courtès <ludo@gnu.org> wrote:

> This should go to xdisorg.scm (xorg.scm is for packages distributed by
> the X.org project).

<snip>

> ‘guix lint’ complains about two-spaces-after-period issues. :-)
>
> Also, s/GUI program/graphical program/ ?

Good catches!
The updated patch is attached.

Best regards,
Paul

Comments

Ludovic Courtès June 11, 2021, 10:42 p.m. UTC | #1
Hi,

"Paul A. Patience" <paul@apatience.com> skribis:

> From 65b9463e159f0e3ff1ae0c4a0faca08b0c22ed81 Mon Sep 17 00:00:00 2001
> From: "Paul A. Patience" <paul@apatience.com>
> Date: Wed, 9 Jun 2021 08:07:44 -0400
> Subject: [PATCH] gnu: Add xkbset.
>
> * gnu/packages/xdisorg.scm (xkbset): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 65b9463e159f0e3ff1ae0c4a0faca08b0c22ed81 Mon Sep 17 00:00:00 2001
From: "Paul A. Patience" <paul@apatience.com>
Date: Wed, 9 Jun 2021 08:07:44 -0400
Subject: [PATCH] gnu: Add xkbset.

* gnu/packages/xdisorg.scm (xkbset): New variable.
---
 gnu/packages/xdisorg.scm | 55 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 55 insertions(+)

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 5573e2afb5..66e1867809 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -46,6 +46,7 @@ 
 ;;; Copyright © 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
 ;;; Copyright © 2021 Renzo Poddighe <renzo@poddighe.nl>
+;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2871,3 +2872,57 @@  Pressing the key again will cycle to the application's next window,
 if there's more than one.")
     (home-page "https://github.com/mkropat/jumpapp")
     (license license:expat)))
+
+(define-public xkbset
+  (package
+    (name "xkbset")
+    (version "0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://faculty.missouri.edu/~stephen/software/"
+                           name "/" name "-" version ".tar.gz"))
+       (sha256
+        (base32 "199mlm127zk1lr8nrq22n68l2l8cjwc4cgwd67rg1i6497n2y0xc"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libx11" ,libx11)
+       ("perl" ,perl)
+       ("perl-tk" ,perl-tk)))
+    (arguments
+     `(#:tests? #f                      ; There are none.
+       #:make-flags
+       `(,,(string-append "CC=" (cc-for-target))
+         ,(string-append "X11PREFIX=" %output)
+         ,(string-append "X11BASE=" (assoc-ref %build-inputs "libx11"))
+         ,(string-append "INSTALL_MAN1=" %output "/share/man/man1"))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-before 'install 'create-install-directories
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (mkdir-p out)
+               (with-directory-excursion out
+                 (for-each mkdir-p '("bin" "share/man/man1"))))
+             #t))
+         (add-after 'install 'wrap-perl-script
+           (lambda* (#:key outputs #:allow-other-keys)
+             (wrap-program (string-append (assoc-ref outputs "out")
+                                          "/bin/xkbset-gui")
+               `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))
+             #t))
+         (replace 'install-license-files
+           (lambda* (#:key outputs #:allow-other-keys)
+             (install-file "COPYRIGHT"
+                           (string-append (assoc-ref outputs "out")
+                                          "/share/doc/" ,name "-" ,version))
+             #t)))))
+    (home-page "https://faculty.missouri.edu/~stephen/software/")
+    (synopsis "User-preference utility for XKB extensions for X")
+    (description
+     "This is a program to help manage many of the XKB features of the X Window
+System.  This includes such features as MouseKeys, AccessX, StickyKeys,
+BounceKeys, and SlowKeys.  It includes a graphical program to help with
+MouseKeys-acceleration management.")
+    (license license:bsd-3)))
-- 
2.31.1