diff mbox series

[bug#58448] gnu: helm: fix not finding Factory Presets

Message ID 1Hb23qlXeqgl88MZf-yTifjb8ONE252Dzr2UuXWINnpJSUKbtAroTIZsmCKV4SuSkQkVihMEVjP6KiHbdhD1qrjB5GZCqIU6TI4ZeSBH9Xc=@proton.me
State New
Headers show
Series [bug#58448] gnu: helm: fix not finding Factory Presets | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sughosha Oct. 11, 2022, 6:34 p.m. UTC
* gnu/packages/music.scm (helm): Fix not finding Factory Presets.
  This change fixes hardcoded paths so that Factory Presets can be found.
---
 gnu/packages/music.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Nicolas Goaziou Oct. 29, 2022, 9:53 p.m. UTC | #1
Hello,

Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/music.scm (helm): Fix not finding Factory Presets.
>   This change fixes hardcoded paths so that Factory Presets can be
>   found.

Thank you.  Applied with the following changes:

> +         (add-after 'unpack 'fix-hardcoded-paths
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (substitute* "src/common/load_save.cpp"
> +               (("/usr") (assoc-ref outputs "out")))
> +             (substitute* "src/editor_sections/patch_browser.cpp"
> +               (("/usr") (assoc-ref outputs "out")))
> +             #t))

I removed trailing #t, and merged both substitute* calls.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6b37c79389..000b372303 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -6144,6 +6144,13 @@  (define-public helm
              (substitute* "Makefile"
                (("/usr") ""))
              #t))
+         (add-after 'unpack 'fix-hardcoded-paths
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "src/common/load_save.cpp"
+               (("/usr") (assoc-ref outputs "out")))
+             (substitute* "src/editor_sections/patch_browser.cpp"
+               (("/usr") (assoc-ref outputs "out")))
+             #t))
          (delete 'configure))))
     (inputs
      `(("alsa-lib" ,alsa-lib)