diff mbox series

[bug#53149] Update Kicad to 6.0.0

Message ID 19pc1sQZe7q77dBcvmMFNJ3D1N3AZxoRrMmkEg03_fFRK_E67EDc8aCaJNmfvr1pAjyQ8uxVyJugXe3SZFFBD5367YWTYLnqvoSGCRVs9mw=@protonmail.com
State Accepted
Headers show
Series [bug#53149] Update Kicad to 6.0.0 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Jan. 9, 2022, 10:45 p.m. UTC
Hi,

this patch series updates Kicad to version 6.0.0. Guix lint shows newer version 6.99.0 but that's intended for development of the next major release.

The list of changes are described here [1].

[1] https://www.kicad.org/blog/2021/12/KiCad-6.0.0-Release/

----
Petr

Comments

Leo Famulari Jan. 11, 2022, 7:54 p.m. UTC | #1
On Sun, Jan 09, 2022 at 10:45:50PM +0000, phodina via Guix-patches via wrote:
> Hi,
> 
> this patch series updates Kicad to version 6.0.0. Guix lint shows newer version 6.99.0 but that's intended for development of the next major release.
> 
> The list of changes are described here [1].
> 
> [1] https://www.kicad.org/blog/2021/12/KiCad-6.0.0-Release/

Thanks for these patches!

They do not apply to the Guix master branch, because our Kicad package
is currently at version 5.1.12. Can you rebase your commits and send a
revised patch series?
diff mbox series

Patch

From 78751a56340b9cd3e267c67dbda920c0316a642d Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Sun, 9 Jan 2022 23:04:57 +0100
Subject: [PATCH 2/3] gnu: kicad: Update to 6.0.0.

* gnu/packages/engineering.scm (kicad): Update to 6.0.0.
  [native-inputs]: Remove kicad-i18n. Use new syntax.
  [inputs]: Add bash-minimal, gtk+ and use opencascade-occt instead of
  opencascade-oce. Use new syntax.
  [arguments]: Remove phase install-translations.

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index eec835f97c..d5a44cf648 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -64,6 +64,7 @@  (define-module (gnu packages engineering)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
@@ -925,7 +926,7 @@  (define-public inspekt3d
 (define-public kicad
   (package
     (name "kicad")
-    (version "5.1.10")
+    (version "6.0.0")
     (source
      (origin
        (method git-fetch)
@@ -933,7 +934,7 @@  (define-public kicad
              (url "https://gitlab.com/kicad/code/kicad.git")
              (commit version)))
        (sha256
-        (base32 "10ix560bqy0lprnik1bprxw9ix4g8w2ipvyikx551ak9ryvgwjcc"))
+        (base32 "1jrfwyi4zs0rpcpsj01z6687a433nnr56cxbnz12jfg2yafpxk23"))
        (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
@@ -942,6 +943,8 @@  (define-public kicad
        #:build-type "Release"
        #:configure-flags
        (list "-DKICAD_SCRIPTING_PYTHON3=ON"
+            (string-append "-DOCC_INCLUDE_DIR=" (assoc-ref %build-inputs
+             "opencascade-occt") "/include/opencascade")
              "-DKICAD_SCRIPTING_WXPYTHON_PHOENIX=ON"
              "-DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE")
        #:phases
@@ -963,11 +966,6 @@  (define-public kicad
              (substitute* "common/lib_tree_model.cpp"
                (("#include <eda_pattern_match.h>" all)
                 (string-append "#include <algorithm>\n" all)))))
-         (add-after 'install 'install-translations
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (copy-recursively (assoc-ref inputs "kicad-i18n")
-                               (assoc-ref outputs "out"))
-             #t))
          (add-after 'install 'wrap-program
            ;; Ensure correct Python at runtime.
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -1003,27 +1001,28 @@  (define-public kicad
             (variable "KISYS3DMOD")     ; 3D model path
             (files '("share/kicad/modules/packages3d")))))
     (native-inputs
-     `(("boost" ,boost)
-       ("desktop-file-utils" ,desktop-file-utils)
-       ("gettext" ,gettext-minimal)
-       ("kicad-i18n" ,kicad-i18n)
-       ("pkg-config" ,pkg-config)
-       ("swig" ,swig)
-       ("zlib" ,zlib)))
+     (list boost
+       desktop-file-utils
+       gettext-minimal
+       pkg-config
+       swig
+       zlib))
     (inputs
-     `(("cairo" ,cairo)
-       ("curl" ,curl)
-       ("glew" ,glew)
-       ("glm" ,glm)
-       ("hicolor-icon-theme" ,hicolor-icon-theme)
-       ("libngspice" ,libngspice)
-       ("libsm" ,libsm)
-       ("mesa" ,mesa)
-       ("opencascade-oce" ,opencascade-oce)
-       ("openssl" ,openssl)
-       ("python" ,python-wrapper)
-       ("wxwidgets" ,wxwidgets)
-       ("wxpython" ,python-wxpython)))
+     (list bash-minimal
+       cairo
+       curl
+       glew
+       glm
+       hicolor-icon-theme
+       libngspice
+       libsm
+       mesa
+       opencascade-occt
+       openssl
+       python-wrapper
+       gtk+
+       wxwidgets
+       python-wxpython))
     (home-page "https://www.kicad.org/")
     (synopsis "Electronics Design Automation Suite")
     (description "Kicad is a program for the formation of printed circuit
-- 
2.34.0