diff mbox series

[bug#73073,v2,8/8] gnu: cgit: Remove input labels.

Message ID 19f279c682308ff8bf719c8073e8c3d10856e08e.1725930587.git.zimon.toutoune@gmail.com
State New
Headers show
Series Allow origin inside inputs with "new style". | expand

Commit Message

Simon Tournier Sept. 10, 2024, 1:27 a.m. UTC
* gnu/packages/version-control.scm (cgit)
[inputs]: Remove labels.
[arguments]<phases>: Adjust.

Change-Id: Iff479fa636f7a4c4fef5137ae22934d4e213223b
---
 gnu/packages/version-control.scm | 50 +++++++++++++++++---------------
 1 file changed, 26 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index a0fdcb0da9..5b28eeaa9e 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1315,7 +1315,7 @@  (define-public cgit
               (lambda* (#:key inputs #:allow-other-keys)
                 ;; Unpack the source of git into the 'git' directory.
                 (invoke "tar" "--strip-components=1" "-C" "git" "-xf"
-                        (assoc-ref inputs "git-source"))))
+                        #$(this-package-input "git-source"))))
             (add-after 'unpack 'patch-absolute-file-names
               (lambda* (#:key inputs outputs #:allow-other-keys)
                 (define (quoted-file-name input path)
@@ -1370,29 +1370,31 @@  (define-public cgit
        ;; For building manpage.
        (list asciidoc))
       (inputs
-       `( ;; Building cgit requires a Git source tree.
-         ("git-source"
-          ,(origin
-             (method url-fetch)
-             ;; cgit is tightly bound to git.  Use GIT_VER from the Makefile,
-             ;; which may not match the current (package-version git).
-             (uri "mirror://kernel.org/software/scm/git/git-2.46.0.tar.xz")
-             (sha256
-              (base32 "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))))
-         ("bash-minimal" ,bash-minimal)
-         ("openssl" ,openssl)
-         ("python" ,python)
-         ("python-docutils" ,python-docutils)
-         ("python-markdown" ,python-markdown)
-         ("python-pygments" ,python-pygments)
-         ("zlib" ,zlib)
-         ;; bzip2, groff, gzip and xz are inputs (not native inputs)
-         ;; since they are actually substituted into cgit source and
-         ;; referenced by the built package output.
-         ("bzip2" ,bzip2)
-         ("groff" ,groff)
-         ("gzip" ,gzip)
-         ("xz" ,xz)))
+       (list
+        ;; Building cgit requires a Git source tree.
+        (origin
+          (method url-fetch)
+          ;; cgit is tightly bound to git.  Use GIT_VER from the Makefile,
+          ;; which may not match the current (package-version git).
+          (uri "mirror://kernel.org/software/scm/git/git-2.46.0.tar.xz")
+          (sha256
+           (base32 "15bzq9m6c033qiz5q5gw1nqw4m452vvqax30wbms6z4bl9i384kz"))
+          (file-name "git-source"))
+        bash-minimal
+        openssl
+        python
+        python-docutils
+        python-markdown
+        python-pygments
+        zlib
+        ;; bzip2, groff, gzip and xz are inputs (not native inputs)
+        ;; since they are actually substituted into cgit source and
+        ;; referenced by the built package output.
+
+        bzip2
+        groff
+        gzip
+        xz))
       (home-page "https://git.zx2c4.com/cgit/")
       (synopsis "Web frontend for git repositories")
       (description