@@ -14,6 +14,7 @@
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -367,14 +368,14 @@ (define-public irssi
(define-public weechat
(package
(name "weechat")
- (version "4.3.6")
+ (version "4.4.0")
(source (origin
(method url-fetch)
(uri (string-append "https://weechat.org/files/src/weechat-"
version ".tar.xz"))
(sha256
(base32
- "16bwch9k6sp7hkgy9pzaw8jrkhzb2yi64m299c7w9p9j2lwhd2w7"))))
+ "0rbxamnvy2vvm6pd2m7j7c3jgb2s5px1173blwyn9mw9x65h31nw"))))
(build-system cmake-build-system)
(outputs '("out" "doc"))
(native-inputs
@@ -409,6 +410,10 @@ (define-public weechat
'()))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-lua-build
+ (lambda* _
+ (substitute* "src/plugins/lua/weechat-lua.c"
+ (("#elif LUA_VERSION") "#elif defined(LUA_VERSION)"))))
,@(if (target-x86?)
'((add-after 'install 'move-doc
(lambda* (#:key outputs #:allow-other-keys)
From: Ashish SHUKLA <ashish.is@lostca.se> * gnu/packages/irc.scm (weechat): Update to 4.4.0. [arguments] add post-unpack function to patch a compilation error. Change-Id: Ie59694e419cc25850b01ed56b3f4ede956e527e4 --- gnu/packages/irc.scm | 9 +++++++-- 1 file changed, 7 insertions(+), 2 deletions(-) base-commit: 6541d382cb5c18703152cbd0c5e5e93d671d6dab