diff mbox series

[bug#69663] gnu: wtype: Fix cross-compiling.

Message ID 19a7169b2d69663ca95c2877af91d71c1493389a.1709958105.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#69663] gnu: wtype: Fix cross-compiling. | expand

Commit Message

Zheng Junjie March 9, 2024, 4:21 a.m. UTC
* gnu/packages/freedesktop.scm (wtype):
[native-inputs]: Remove libxkbcommon.
[inputs]: Add wayland, libxkbcommon.

Change-Id: I010369e6a98d68bc30246ef6dec2cef6a4fe4d21
---
 gnu/packages/freedesktop.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)


base-commit: e51c26ef2daf7742eb1617ecb2c7f1594b73fb0c

Comments

宋文武 March 19, 2024, 11:19 a.m. UTC | #1
Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/freedesktop.scm (wtype):
> [native-inputs]: Remove libxkbcommon.
> [inputs]: Add wayland, libxkbcommon.

Pushed as 755838a378, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 7b5d2dbbf2..a6d6ad81da 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2023 Alex Devaure <ajadevaure@gmail.com>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1463,7 +1464,10 @@  (define-public wtype
         (base32 "0bpix92vzip9vlhzihj3k8h9flrlna231x3y8ah7p4965l177yjd"))))
     (build-system meson-build-system)
     (native-inputs
-     (list pkg-config wayland libxkbcommon))
+     (list pkg-config
+           ;; for wayland-scanner
+           wayland))
+    (inputs (list wayland libxkbcommon))
     (synopsis "Xdotool type for Wayland")
     (description "Wtype lets you simulate keyboard input and mouse activity,
 move and resize windows, etc.")