[bug#75384,1/4] gnu: Add c-ares-for-node-lts.
Commit Message
From: Jelle Licht <jlicht@fsfe.org>
* gnu/packages/adns.scm (c-ares-for-node-lts): New variable.
Change-Id: I547272f3fa3419a7659bf5b2d91a3e917c20d434
---
gnu/packages/adns.scm | 15 +++++++++++++++
1 file changed, 15 insertions(+)
@@ -148,6 +148,21 @@ (define-public c-ares
multiple clients and programs with graphical user interfaces.")
(license (x11-style "https://c-ares.haxx.se/license.html"))))
+(define-public c-ares-for-node-lts
+ (hidden-package
+ (package
+ (inherit c-ares)
+ (version "1.34.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/c-ares/c-ares/releases/download/v"
+ version "/c-ares-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0br2msk3bpl5myhjp9vr5j2scpspvbg2fpnz69dcrr4ycpnxnf7s")))))))
+
;; gRPC requires a c-ares built with CMake in order to get the .cmake modules.
;; We can not build c-ares itself with CMake because that would introduce a
;; circular dependency through nghttp2.