diff mbox series

[bug#73305,2/2] gnu: python-pycurl: Build from git.

Message ID 196054ea15207a26c7d9f3daf24334418333caf4.1726520125.git.attila@lendvai.name
State New
Headers show
Series [bug#73305,1/2] gnu: python-pycurl: Fix build by running the tests single-threaded. | expand

Commit Message

Attila Lendvai Sept. 16, 2024, 8:55 p.m. UTC
From: Attila Lendvai <attila@lendvai.name>

Change-Id: I1b347c04022970ffe42a87530e525a83745ff84c
---
 gnu/packages/python-web.scm | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 94e349bedb0..2dfbf5b66e5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2017,10 +2017,15 @@  (define-public python-pycurl
     (version "7.45.2")
     (source
      (origin
-       (method url-fetch)
-       (uri (pypi-uri "pycurl" version))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/pycurl/pycurl")
+             (commit (string-append
+                      "REL_" (string-replace-substring version "." "_")))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1ji46b924caa4saxvjxs9h673yy0kif297nxpnjn84r7w05mjc2p"))))
+        (base32
+         "1dzdramcgf63m1zg8glhqa3ik9anzjy954mshk7s3z3gsi21n8fp"))))
     (build-system pyproject-build-system)
     (arguments
      '(#:test-flags