[bug#75522,v2,3/3] gnu: Add beanbag.

Message ID 195c84842ac.63d5dd6d258144.2933637696280936882@zohomail.in
State New
Headers
Series None |

Commit Message

Ashvith Shetty March 24, 2025, 1:12 p.m. UTC
  * gnu/packages/zig-xyz.scm (beanbag): New variable.

Change-Id: I1ffb34dd771e4cb0938f1c471573e6bbe1ff5046
---
 gnu/packages/zig-xyz.scm | 40 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)
  

Patch

diff --git a/gnu/packages/zig-xyz.scm b/gnu/packages/zig-xyz.scm
index 37c6e27e0a..9d4d02c02d 100644
--- a/gnu/packages/zig-xyz.scm
+++ b/gnu/packages/zig-xyz.scm
@@ -38,6 +38,46 @@  (define-module (gnu packages zig-xyz)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages zig))
 
+(define-public beanbag
+  (package
+    (name "beanbag")
+    (version "0.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://codeberg.org/bwbuhse/beanbag")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1d2h5bqicqnyawswdq7bg1w9frjk0ra2sva1as2qgc5s7pjclyql"))
+       (snippet (rename-zig-dependencies '(("clap" . "zig-clap")
+                                           ("zigimg" . "zig-img"))))))
+    (build-system zig-build-system)
+    (arguments
+     (list
+      ;; Nothing to test
+      #:tests? #f
+      #:install-source? #f
+      #:zig-release-type "safe"
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'remove-deps
+            (lambda* (#:key inputs #:allow-other-keys)
+              (delete-file-recursively "protocol")
+              (substitute* "build.zig"
+                (("protocol\\/wlr-layer-shell-unstable-v1.xml")
+                 (string-append (search-input-file inputs
+                  "share/wlr-protocols/unstable/wlr-layer-shell-unstable-v1.xml")))))))))
+    (inputs (list zig-clap zig-img zig-pixman zig-wayland))
+    (native-inputs (list pkg-config wlr-protocols))
+    (home-page "https://codeberg.org/bwbuhse/beanbag")
+    (synopsis "Wallpaper app for Wayland compositors")
+    (description
+     "@code{beanbag} is a wallpaper app for Wayland compositors, heavily inspired by
+     dnkl's @code{wbg}.")
+    (license license:gpl3)))
+
 (define-public river
   (package
     (name "river")