[bug#75522,v2,1/3] gnu: Add zig-clap.
Commit Message
* gnu/packages/zig-xyz.scm (zig-clap): New variable.
Change-Id: Iae01f44bd9ddb312b51cf899c24f6b56a808d026
---
gnu/packages/zig-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)
@@ -3,6 +3,7 @@
;;; Copyright © 2023 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2024 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2025 Ashvith Shetty <ashvithshetty0010@zohomail.in>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -141,6 +142,27 @@ (define-public waylock
@code{ext-session-lock-v1} protocol.")
(license license:expat)))
+(define-public zig-clap
+ (package
+ (name "zig-clap")
+ (version "0.9.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Hejsil/zig-clap")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xjskvyib3kai3nmp574zfm07yvjsbzsxfysj96ss9339nq07ix6"))))
+ (build-system zig-build-system)
+ (home-page "https://github.com/Hejsil/zig-clap")
+ (synopsis "Command line argument parsing library for Zig")
+ (description
+ "@code{zig-clap} is a simple and easy to use command line argument parser library for
+Zig.")
+ (license license:expat)))
+
(define-public zig-diffz
(let ((commit "420fcb22306ffd4c9c3c761863dfbb6bdbb18a73")
(revision "0"))