diff mbox series

[bug#42751] gnu: Add cfunge.

Message ID 1926083374.1509159.1596819760388@mail.yahoo.com
State Accepted
Headers show
Series [bug#42751] gnu: Add cfunge. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

ashish.is--- via Guix-patches" via Aug. 7, 2020, 5:02 p.m. UTC
I added a new file, esolangs.scm, because I could not find any other place to be more appropriate, for this and forthcoming packages.

- Hendursaga

Comments

Maja Kądziołka Aug. 9, 2020, 8:50 p.m. UTC | #1
On Fri, Aug 07, 2020 at 05:02:40PM +0000, Hendur Saga wrote:
> I added a new file, esolangs.scm, because I could not find any other place to be more appropriate, for this and forthcoming packages.

Not a bad idea, though toys.scm somewhat fits. Please add the new file
to the list in gnu/local.mk, though.

Also, could you run your code through etc/indent-code.el?

> +   (arguments
> +     '(#:tests? #f)) ; no make target 'test'

The repository does contain a tests/ folder, did you try running these?
You can check the rgbds package from assembly.scm for some inspiration
as to how you can handle a custom testsuite entrypoint.

> +   (inputs
> +    `(("ncurses" ,ncurses)))
> +   (home-page "https://github.com/VorpalBlade/cfunge")
> +   (synopsis "Fast conforming Befunge93/98/109 interpreter in C")
> +   (description "cfunge is a fast conforming Befunge93/98/109 interpreter written in C.
           @command{cfunge}

> +It supports several fingerprints.")

It would be nice to define what a fingerprint is, as even though there
was once a summer when I was fluent in Befunge, I still needed a longer
moment to recall what those are. How about this Texinfo markup?

@dfn{fingerprints} (opt-in language extensions identified by a
four-character code).

> +   (license license:gpl2+)))

COPYING and the headers in src/*.c (well, I checked diagnostic.c)
suggest that it's actually gpl3+, what gives?

Could you send an updated patch?

Regards,
Jakub Kądziołka

P.S. I tried to test the package by running this CGCC answer in it, but
it loops infinitely. I didn't have time to debug this, so I don't know
where the blame lies.

https://codegolf.stackexchange.com/a/150920/55934
diff mbox series

Patch

From 2d3277c651754178d42ed1edded50375b74dc992 Mon Sep 17 00:00:00 2001
From: Hendursaga <hendursaga@yahoo.com>
Date: Thu, 6 Aug 2020 18:43:20 +0000
Subject: [PATCH] gnu: Add cfunge.

* gnu/packages/esolangs.scm (cfunge): New variable.
---
 gnu/packages/esolangs.scm | 49 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)
 create mode 100644 gnu/packages/esolangs.scm

diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
new file mode 100644
index 0000000000..bc4918b226
--- /dev/null
+++ b/gnu/packages/esolangs.scm
@@ -0,0 +1,49 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages esolangs)
+  #:use-module (gnu packages ncurses)
+  #:use-module (guix build-system cmake)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages))
+
+(define-public cfunge
+  (package
+   (name "cfunge")
+   (version "0.9.0")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/VorpalBlade/cfunge")
+                  (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "18ir0h10vxdb5jb57w5hjbgi8spjxg9x2148agadhhmbhsja02m7"))))
+   (build-system cmake-build-system)
+   (arguments
+     '(#:tests? #f)) ; no make target 'test'
+   (inputs
+    `(("ncurses" ,ncurses)))
+   (home-page "https://github.com/VorpalBlade/cfunge")
+   (synopsis "Fast conforming Befunge93/98/109 interpreter in C")
+   (description "cfunge is a fast conforming Befunge93/98/109 interpreter written in C.
+It supports several fingerprints.")
+   (license license:gpl2+)))
-- 
2.28.0