diff mbox series

[bug#66629] gnu: Add popf.

Message ID 18e8d05647e142478274eb122ad017bb46475e97.1697700674.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#66629] gnu: Add popf. | expand

Commit Message

Liliana Marie Prikler Oct. 19, 2023, 7:30 a.m. UTC
* gnu/packages/maths.scm (popf): New variable.
---
 gnu/packages/maths.scm | 48 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)


base-commit: 8d6b3dd0b863ccada887da8cd347727dd04cb456
prerequisite-patch-id: 2c53125d93acdbe9e68218b2015414f5435e7c92

Comments

Liliana Marie Prikler Oct. 27, 2023, 2:40 p.m. UTC | #1
Am Donnerstag, dem 19.10.2023 um 09:30 +0200 schrieb Liliana Marie
Prikler:
> * gnu/packages/maths.scm (popf): New variable.
> ---
Pushed.
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 683acd96e1..c1e6b06a26 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3179,6 +3179,54 @@  (define-public fast-downward
 supports the propositional fragment of PDDL2.2.")
     (license license:gpl3+)))
 
+(define popf
+  (package
+    (name "popf")
+    (version "0.0.15")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fmrico/popf")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1i1am3h6japn8fgapi5s5mnyrm31a05jkjhzgk48cd2n42c5060v"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list
+      #:tests? #f                       ; no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'fix-cmake
+            (lambda* (#:key inputs #:allow-other-keys)
+              (substitute* (find-files "." "CMakeLists\\.txt")
+                (("/usr/local/opt/flex/include")
+                 (dirname (search-input-file inputs "include/FlexLexer.h"))))
+              (substitute* "CMakeLists.txt"
+                (("find_package\\(ament_cmake REQUIRED\\)") "")
+                (("ament_.*") "")
+                (("(RUNTIME DESTINATION) .*" all dst)
+                 (string-append dst " libexec/${PROJECT_NAME}")))))
+          (add-after 'install 'symlink
+            (lambda* (#:key outputs #:allow-other-keys)
+              (let ((out (assoc-ref outputs "out")))
+                (mkdir-p (string-append out "/bin"))
+                (for-each (lambda (link)
+                            (symlink
+                             (string-append out "/libexec/popf/" (cdr link))
+                             (string-append out "/bin/" (car link))))
+                          '(("popf" . "popf") ("VAL" . "validate")))))))))
+    (inputs (list cbc flex))
+    (native-inputs (list flex bison perl))
+    (home-page "https://github.com/fmrico/popf")
+    (synopsis "Forward-chaining temporal planner")
+    (description "This package contains an implementation of the @acronym{POPF,
+Partial Order Planning Forwards} planner described in @cite{Forward-Chaining
+Partial Order Planning}, that has been updated to compile with newer C++
+compilers.")
+    (license license:gpl2+)))
+
 (define-public gmsh
   (package
     (name "gmsh")