diff mbox series

[bug#55637] gnu: Add python-canopen.

Message ID 18cb9db1fe8214e9dd37a70746252e8f118890c0.1653676589.git.peter@polidoro.io
State Accepted
Headers show
Series [bug#55637] gnu: Add python-canopen. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Peter Polidoro May 27, 2022, 6:37 p.m. UTC
From: Peter Polidoro <peter@polidoro.io>

* gnu/packages/python-xyz.scm (python-canopen): New variable.
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44eeb0d7fe..3ae14765dc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2248,6 +2248,27 @@  (define-public python-can
 sending and receiving messages on a CAN bus.")
     (license license:lgpl3+)))
 
+(define-public python-canopen
+  (package
+    (name "python-canopen")
+    (version "2.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "canopen" version))
+       (sha256
+        (base32 "1nb543wb37kj95v6bhh272lm5gkpi41q3pnsl1fxlyizm2gamj5w"))))
+    (build-system python-build-system)
+    (native-inputs (list python-packaging))
+    (propagated-inputs (list python-can))
+    (home-page "https://github.com/christiansandberg/canopen")
+    (synopsis "CANopen stack implementation")
+    (description "A Python implementation of the CANopen standard.  The aim of
+the project is to support the most common parts of the CiA 301 standard in a
+simple Pythonic interface.  It is mainly targeted for testing and automation
+tasks rather than a standard compliant master implementation.")
+    (license license:expat)))
+
 (define-public python-caniusepython3
   (package
     (name "python-caniusepython3")