diff mbox series

[bug#60153,v1,2/3] gnu: python-pygame: Use gexps and new style inputs.

Message ID 1871bcf2-19a8-1928-0244-710d8fcab224@disroot.org
State New
Headers show
Series [bug#60153,v1,1/3] gnu: python-pygame: Update to 2.1.2. | expand

Commit Message

Adam Faiz Dec. 18, 2022, 3:54 p.m. UTC
From 76f9b1970a8dfb11108823be8dc0f16b1d0861a7 Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Sun, 18 Dec 2022 23:20:27 +0800
Subject: [PATCH v1 2/3] gnu: python-pygame: Use gexps and new style inputs.

* gnu/packages/game-development.scm (python-pygame)[arguments]: Use gexps.
[inputs]: Use the new style.
---
  gnu/packages/game-development.scm | 40 +++++++++++++++----------------
  1 file changed, 20 insertions(+), 20 deletions(-)

      (synopsis "SDL wrapper for Python")
      (description "Pygame is a set of Python modules designed for 
writing games.
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm 
b/gnu/packages/game-development.scm
index f9a53799f5..a96f62603f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1225,29 +1225,29 @@  (define-public python-pygame
                       (("SDL_mixer.h") "SDL2/SDL_mixer.h"))))))
      (build-system python-build-system)
      (arguments
-     `(#:tests? #f                ; tests require pygame to be 
installed first
-       #:phases
-       (modify-phases %standard-phases
-         ;; Pass the dependencies to the configure script
-         ;; through environment variables.
-         (add-before 'build 'set-library-paths
-           (lambda _
-             (setenv "LOCALBASE" " "))))))
+     (list #:tests? #f              ; tests require pygame to be 
installed first
+           #:phases
+           #~(modify-phases %standard-phases
+             ;; Pass the dependencies to the configure script
+             ;; through environment variables.
+             (add-before 'build 'set-library-paths
+               (lambda _
+                 (setenv "LOCALBASE" " "))))))
      (native-inputs
       (list pkg-config))
      (inputs
-     `(("freetype" ,freetype)
-       ("sdl2" ,sdl2)
-       ("sdl2-image" ,sdl2-image)
-       ("sdl2-mixer" ,sdl2-mixer)
-       ("sdl2-ttf" ,sdl2-ttf)
-       ("sdl2-gfx" ,sdl2-gfx)
-       ("libjpeg" ,libjpeg-turbo)
-       ("libpng" ,libpng)
-       ("libX11" ,libx11)
-       ("libsmpeg" ,libsmpeg)
-       ("portmidi" ,portmidi)
-       ("v4l-utils" ,v4l-utils)))
+     (list freetype
+           sdl2
+           sdl2-image
+           sdl2-mixer
+           sdl2-ttf
+           sdl2-gfx
+           libjpeg-turbo
+           libpng
+           libx11
+           libsmpeg
+           portmidi
+           v4l-utils))
      (home-page "https://www.pygame.org")