diff mbox series

[bug#66689,gnome-team,v3,10/17] gnu: python-pygobject: Update style.

Message ID 186a3f8df69a6c35b7d7e64d95aab0c58237386d.1698176625.git.vivien@planete-kraus.eu
State New
Headers show
Series Update glib.scm with separate style commits | expand

Commit Message

Vivien Kraus Oct. 24, 2023, 3:40 p.m. UTC
* gnu/packages/glib.scm (python-pygobject) [origin sha256]: Update indentation.
[snippet]: Convert to G-Expression. Remove trailing #f.
[arguments]: Convert to list of G-Expressions.
[native-inputs]: Drop labels.

Change-Id: I325de196b79cbdd0acaed3c40be42aa7335abcae
---
 gnu/packages/glib.scm | 42 ++++++++++++++++++++----------------------
 1 file changed, 20 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 2c813fd594..1012d2190b 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -1015,33 +1015,31 @@  (define-public python-pygobject
                            (version-major+minor version)
                            "/pygobject-" version ".tar.xz"))
        (sha256
-        (base32
-         "1z6aagb46fhhdd0bb3zk6dfdw3s4y2fva0vv3jpwjj6mvar0hq22"))
+        (base32 "1z6aagb46fhhdd0bb3zk6dfdw3s4y2fva0vv3jpwjj6mvar0hq22"))
        (modules '((guix build utils)))
        (snippet
-        '(begin
-           ;; We disable these tests in a snippet so that they are inherited
-           ;; by the Python 2 variant which is built differently.
-           (with-directory-excursion "tests"
-             ;; FIXME: These tests require Gdk and/or Gtk 4.
-             (for-each delete-file
-                       '("test_atoms.py" "test_overrides_gtk.py"
-                         "test_overrides_gdk.py"))
-             #t)))))
+        ;; We disable these tests in a snippet so that they are inherited
+        ;; by the Python 2 variant which is built differently.
+        #~(with-directory-excursion "tests"
+            ;; FIXME: These tests require Gdk and/or Gtk 4.
+            (for-each delete-file
+                      '("test_atoms.py" "test_overrides_gtk.py"
+                        "test_overrides_gdk.py"))))))
     (build-system meson-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             (when tests?
-               ;; The default 90 seconds can be too low on slower machines.
-               (invoke "meson" "test" "--timeout-multiplier" "5")))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? #:allow-other-keys)
+              (when tests?
+                ;; The default 90 seconds can be too low on slower machines.
+                (invoke "meson" "test" "--timeout-multiplier" "5")))))))
     (native-inputs
-     `(("glib-bin" ,glib "bin")
-       ("pkg-config" ,pkg-config)
-       ("python-pytest" ,python-pytest)
-       ("python-wrapper" ,python-wrapper))) ; For patching shebangs
+     (list `(,glib "bin")
+           pkg-config
+           python-pytest
+           python-wrapper)) ; For patching shebangs
     (inputs
      (list python python-pycairo gobject-introspection))
     (propagated-inputs