diff mbox series

[bug#50575] gnu: kdenlive: Update to 21.08.1.

Message ID 1860151576.68171.1631669731404@office.mailbox.org
State Accepted
Headers show
Series [bug#50575] gnu: kdenlive: Update to 21.08.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Brendan Tildesley Sept. 15, 2021, 1:35 a.m. UTC
I think rttr can be removed as a dependency.

Also, It is also possible to switch qt-build-system. In this case, the manual XDG_DATA_DIRS, QT_PLUGIN_PATH, and QML2_IMPORT_PATH wrappers can be removed. The resulting wrapper is slightly different but I think equivalent.
I attached a patch I made last week. If you think it's good you can use that or make it in to your own patch.

Also, there is another kdenlive bug report here https://issues.guix.gnu.org/38450 . I think this bug actually isn't
present any more. To the reviewer of this kdenlive update, if you have the time, maybe also check if that bug occurs, and if not close it. Thanks.

Comments

Vinicius Monego Sept. 15, 2021, 2:06 p.m. UTC | #1
Em qua, 2021-09-15 às 03:35 +0200, Brendan Tildesley escreveu:
> I think rttr can be removed as a dependency.

Removed rttr because it's conditional to the CRASH_AUTO_TEST option in
CMakeLists.txt, which is set to OFF by default.

> Also, It is also possible to switch qt-build-system. In this case,
> the manual XDG_DATA_DIRS, QT_PLUGIN_PATH, and QML2_IMPORT_PATH
> wrappers can be removed. The resulting wrapper is slightly different
> but I think equivalent.
> I attached a patch I made last week. If you think it's good you can
> use that or make it in to your own patch.

Added as a second patch in the series, though I didn't move the phase
after 'wrap. Not sure if it makes a difference?

> Also, there is another kdenlive bug report here  
> https://issues.guix.gnu.org/38450 . I think this bug actually isn't
> present any more. To the reviewer of this kdenlive update, if you
> have the time, maybe also check if that bug occurs, and if not close
> it. Thanks.

The issue doesn't happen in this particular build. I didn't test the
current version because there are no substitutes for it at the moment,
but it's most likely working there too.
diff mbox series

Patch

From 0d5ffb19097157ec6c3f3d2ad2277186c53c88e6 Mon Sep 17 00:00:00 2001
From: Brendan Tildesley <mail@brendan.scot>
Date: Tue, 7 Sep 2021 00:29:13 +1000
Subject: [PATCH] gnu: kdenlive: Use qt-build-system.

gnu/packages/kde.scm (kdenlive): Use qt-build-system.
---
 gnu/packages/kde.scm | 15 +++------------
 1 file changed, 3 insertions(+), 12 deletions(-)

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index aff3ed51ed..0cabf82ce8 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -232,7 +232,7 @@  browser for easy news reading.")
          (file-name (string-append name "-" version "-checkout"))
          (sha256
           (base32 "0x0qfwf6wfnybjyjvmllpf87sm27d1n2akslhp2k8ins838qy55i"))))
-      (build-system cmake-build-system)
+      (build-system qt-build-system)
       (native-inputs
        `(("extra-cmake-modules" ,extra-cmake-modules)
          ("pkg-config" ,pkg-config)
@@ -272,28 +272,19 @@  browser for easy news reading.")
        `(#:tests? #f                    ;TODO needs X
          #:phases
          (modify-phases %standard-phases
-           (add-after 'install 'wrap-executable
+           (add-after 'wrap 'wrap-executable
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
                       (qtbase (assoc-ref inputs "qtbase"))
                       (frei0r (assoc-ref inputs "frei0r-plugins"))
-                      (ffmpeg (assoc-ref inputs "ffmpeg"))
-                      (breeze (assoc-ref inputs "breeze"))
-                      (breeze-icons (assoc-ref inputs "breeze-icons")))
+                      (ffmpeg (assoc-ref inputs "ffmpeg")))
                  (wrap-program (string-append out "/bin/kdenlive")
                    `("PATH" ":" prefix
                      ,(list (string-append ffmpeg "/bin")))
-                   `("XDG_DATA_DIRS" ":" prefix
-                     ,(list (string-append breeze "/share")
-                            (string-append breeze-icons "/share")))
-                   `("QT_PLUGIN_PATH" ":" prefix
-                     ,(list (getenv "QT_PLUGIN_PATH")))
                    `("FREI0R_PATH" ":" =
                      (,(string-append frei0r "/lib/frei0r-1/")))
                    `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
                      (,(string-append qtbase "/lib/qt5/plugins/platforms")))
-                   `("QML2_IMPORT_PATH" ":" prefix
-                     ,(list (getenv "QML2_IMPORT_PATH")))
                    `("MLT_PREFIX" ":" =
                      (,(assoc-ref inputs "mlt")))))
                #t)))))
-- 
2.33.0