diff mbox series

[bug#63486,2/3] gnu: python-txtorcon: Run guix style.

Message ID 183c2901a0250f71ddf1d45ff8b45573a28bffda.1683996444.git.juli@incana.org
State New
Headers show
Series gnu: python-txtorcon: Fix build, style, update. | expand

Commit Message

Juliana Sims May 13, 2023, 4:59 p.m. UTC
* gnu/packages/python-crypto.scm (python-txtorcon): Run guix style.
---
 gnu/packages/python-crypto.scm | 43 ++++++++++++++++------------------
 1 file changed, 20 insertions(+), 23 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index ab2312a1e2..8e94d54336 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1247,31 +1247,28 @@  (define-public python-txtorcon
   (package
     (name "python-txtorcon")
     (version "19.0.0")
-    (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "txtorcon" version))
-        (sha256
-         (base32
-          "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))
-        (modules '((guix build utils)))
-        (snippet
-         #~(substitute* "txtorcon/controller.py"
-             (("from collections import Sequence")
-              "from collections.abc import Sequence")))))
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "txtorcon" version))
+              (sha256
+               (base32
+                "0fxzhsc62bhmr730vj9pzallmw56gz6iykvl28a5agrycm0bfc9p"))
+              (modules '((guix build utils)))
+              (snippet #~(substitute* "txtorcon/controller.py"
+                           (("from collections import Sequence")
+                            "from collections.abc import Sequence")))))
     (build-system python-build-system)
     (arguments
-      ;; The tests fail immediately due to a missing file. Reported upstream:
-      ;; <https://github.com/meejah/txtorcon/issues/330>
-     `(#:tests? #f))
-    (propagated-inputs
-     (list python-automat
-           python-idna
-           python-incremental
-           python-pyopenssl
-           python-service-identity
-           python-twisted
-           python-zope-interface))
+     ;; The tests fail immediately due to a missing file. Reported upstream:
+     ;; <https://github.com/meejah/txtorcon/issues/330>
+     (list #:tests? #f))
+    (propagated-inputs (list python-automat
+                             python-idna
+                             python-incremental
+                             python-pyopenssl
+                             python-service-identity
+                             python-twisted
+                             python-zope-interface))
     (home-page "https://github.com/meejah/txtorcon")
     (synopsis "Twisted-based Tor controller client")
     (description "This package provides a Twisted-based Tor controller client,