[bug#76746,12/13] gnu: Add python-spotipy.
Commit Message
* gnu/packages/python-web.scm (python-spotipy): New variable.
Change-Id: Id1d2a46997eb1dab9be6951a1b2d9f5a43083863
---
gnu/packages/python-web.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
@@ -10785,6 +10785,29 @@ (define-public python-pytube
command-line utility) for downloading YouTube videos.")
(license license:unlicense)))
+(define-public python-spotipy
+ (package
+ (name "python-spotipy")
+ (version "2.24.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "spotipy" version))
+ (sha256
+ (base32 "03gg9631nrgsq7daj6w70na77ha2wzghq9spy4d5b1i0chgghsir"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-redis python-requests python-urllib3))
+ (native-inputs (list python-pytest python-setuptools python-wheel))
+ (arguments
+ '(#:tests? #f)) ;tests require network
+ (home-page "https://spotipy.readthedocs.io/en/2.25.0/")
+ (synopsis "Python library for the Spotify Web API")
+ (description
+ "Spotipy is a lightweight Python library for the Spotify Web API. It aims
+to provide full access to all of the music data provided by the Spotify
+platform.")
+ (license license:expat)))
+
(define-public python-whatthepatch
(package
(name "python-whatthepatch")