diff mbox series

[bug#61979] gnu: tracker: Increase timeout multiplier.

Message ID 17f24d1cc840801e71ac137e2123499509cf91d5.camel@gmail.com
State New
Headers show
Series [bug#61979] gnu: tracker: Increase timeout multiplier. | expand

Commit Message

Liliana Marie Prikler March 5, 2023, 1:18 p.m. UTC
One test fails due to timeout on CI, but succeeds on a strong enough machine
with little load.

* gnu/packages/gnome.scm (tracker)[#:test-options]: Double timeout multipliers.
---
 gnu/packages/gnome.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Liliana Marie Prikler March 12, 2023, 8:15 a.m. UTC | #1
Am Sonntag, dem 05.03.2023 um 14:18 +0100 schrieb Liliana Marie
Prikler:
> One test fails due to timeout on CI, but succeeds on a strong enough
> machine with little load.
> 
> * gnu/packages/gnome.scm (tracker)[#:test-options]: Double timeout
> multipliers.
> ---
Seems to have worked out on QA – let's hope it'll remain that way.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0b7d10c6a8..dafcb33ede 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9679,8 +9679,8 @@  (define-public tracker
      (list
       #:glib-or-gtk? #t
       #:test-options `(list ,@(if (target-riscv64?)
-                                  `("--timeout-multiplier" "5")
-                                  '()))
+                                  `("--timeout-multiplier" "10")
+                                  '("--timeout-multiplier" "2")))
       #:configure-flags
       ;; Otherwise, the RUNPATH will lack the final path component.
       #~(list (string-append "-Dc_link_args=-Wl,-rpath="