diff mbox series

[bug#65330,v1] Fixing tilix compile issues by including updates

Message ID 17bcec724e8a16665c3f17079ced6ac46bff7e98.1692591975.git.aaron.covrig.us@ieee.org
State New
Headers show
Series [bug#65330,v1] Fixing tilix compile issues by including updates | expand

Commit Message

Aaron Covrig Aug. 21, 2023, 4:26 a.m. UTC
1. Changed tilix from v1.9.5 to v1.9.5 + commits
---
This revision changes the version to reflect that this is built
upon v1.9.5 with added commits, rather than being v1.9.6;
additionally, it corrects line spacing so that only the
changed parts are seen as modified by git
 gnu/packages/terminals.scm | 26 +++++++++++++++-----------
 1 file changed, 15 insertions(+), 11 deletions(-)


base-commit: 7cad70566322262f6acdbbb965e867e34010eb55
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 5fc72d7937..fd55233a5b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2022 Felipe Balbi <balbi@kernel.org>
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1339,18 +1340,21 @@  (define-public wterm
   (deprecated-package "wterm" foot))
 
 (define-public tilix
+(let ((commit "e2c75f417a84ad784735524f1b8bf01c516f705d")
+      (revision "0"))
   (package
     (name "tilix")
-    (version "1.9.5")
-    (source
-      (origin
-        (method git-fetch)
-        (uri (git-reference
-               (url "https://github.com/gnunn1/tilix")
-               (commit version)))
-        (file-name (git-file-name name version))
-       (sha256
-        (base32 "1ij3ix6yhi8hicxvglrxjyyv8bch9birrgsr8ml6jfh3hvk4pxdh"))))
+    ;; includes commits that fix glibc related build issues
+    (version (git-version "1.9.5" revision commit))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gnunn1/tilix")
+                    (commit commit)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1k5r99c9ab1l0v37hs1zy08rspgv8n7y3bd13ljqg607cyalbgbf"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -1394,7 +1398,7 @@  (define-public tilix
 terminal are replicated to the others.
 @item Supports notifications when processes are completed out of view.
 @end enumerate")
-    (license license:mpl2.0)))
+    (license license:mpl2.0))))
 
 (define-public tio
   (package