diff mbox series

[bug#73070,v2,2/4] gnu: python-readme-renderer: Update to 41.0.

Message ID 17b3c3519e3ac639a55743378f2ce44fd993c652.1726958372.git.steve@futurile.net
State New
Headers show
Series Series updating python-twine & python-altair | expand

Commit Message

Steve George Sept. 21, 2024, 10:47 p.m. UTC
From: Ricardo Wurmus <rekado@elephly.net>

* gnu/packages/python-xyz.scm (python-readme-renderer): Update to 41.0.
[build-system]: Use pyproject-build-system.
[arguments]: Delete 'loosen-cmarkgfm-dependency phase; replace custom 'check
phase with #:test-flags.
[native-inputs]: Add python-wheel; remove python-mock.

Reviewed-by: Steve George <steve@futurile.net>
Change-Id: I47cef84089384d2cf760c166fed9147863d1a415
---
 gnu/packages/python-xyz.scm | 42 ++++++++++++++++++-------------------
 1 file changed, 20 insertions(+), 22 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f79821e86d..503d8f510f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -32015,38 +32015,36 @@  (define-public python-blessed
 (define-public python-readme-renderer
   (package
     (name "python-readme-renderer")
-    (version "34.0")
+    (version "41.0")
     (source
       (origin
         (method url-fetch)
         (uri (pypi-uri "readme_renderer" version))
         (sha256
          (base32
-          "1c75h9znffc2lh4j56yg23l5ifj5l8fbdq3kfigi8vbh45zx3d6z"))))
-    (build-system python-build-system)
+            "1xvkf2i075rdqkwdrcrw4xglziqd7qs5lb2rbxr5snizi7ji2jsg"))))
+    (build-system pyproject-build-system)
     (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'loosen-cmarkgfm-dependency
-                    (lambda _
-                      ;; Permit newer versions of cmarkgfm.
-                      (substitute* "setup.py"
-                        (("cmarkgfm>=0\\.5\\.0,<0\\.7\\.0")
-                         "cmarkgfm>=0.5.0"))))
-                  (replace 'check
-                    (lambda* (#:key tests? #:allow-other-keys)
-                      (when tests?
-                        ;; The GFM tests fail due to slight differences in the
-                        ;; generated vs expected HTML due to using a more
-                        ;; recent bleach version (see:
-                        ;; https://github.com/pypa/readme_renderer/issues/234).
-                        (invoke "pytest" "-vv" "-k" "not GFM")))))))
-    (propagated-inputs
-     (list python-bleach python-docutils python-pygments
-
+     (list
+      #:test-flags
+      '(list "-k"
+             (string-append
+              ;; These tests fail due to slight differences in the generated
+              ;; vs expected HTML, e.g. because of difference in whitespace or
+              ;; line breaks. (See also
+              ;; https://github.com/pypa/readme_renderer/issues/234).
+              "not test_md_fixtures[test_CommonMark_008.md]"
+              " and not test_rst_fixtures[test_rst_008.rst]"
+              " and not GFM"))))
+    (propagated-inputs
+     (list python-bleach
+           python-docutils
+           python-pygments
            ;; Optional dependencies.
            python-cmarkgfm))           ;required by postorius
     (native-inputs
-     (list python-mock python-pytest))
+     (list python-pytest
+           python-wheel))
     (home-page "https://github.com/pypa/readme_renderer")
     (synopsis "Render README files in Warehouse")
     (description