diff mbox series

[bug#70483,1/1] gnu: Add python-robotframework-requests.

Message ID 17b3a3b413725d7186ed7905c5c761f86b73d986.1713525337.git.markku.korkeala@iki.fi
State New
Headers show
Series [bug#70483,1/1] gnu: Add python-robotframework-requests. | expand

Commit Message

Markku Korkeala April 20, 2024, 8:41 a.m. UTC
* gnu/packages/python-xyz.scm (python-robotframework-requests): New variable.

Change-Id: I01d814d1a9e20d26e9bfa4a0a77ba91577da2bd8
---
 gnu/packages/python-xyz.scm | 38 +++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)


base-commit: ee9cf4f00bcb8966fa125787e8534580b270bb99

Comments

Sharlatan Hellseher April 20, 2024, 5:22 p.m. UTC | #1
Hi!

Thank you for the patch.

There are some modification which need to be applied in v2.

The package is more suitable for python-web.

- [source]: 
- [build-system]: Swap to pyprject-build-system to simplify the package.
- [arguments]: Relay on default check phase.
- [native-inputs]: Remove duplicates, remove python-flake8, remove-coverage.
- [description]: Fix indentation.
Sharlatan Hellseher April 24, 2024, 9:36 a.m. UTC | #2
Pushed as 22d11dab8b09d8aed780d5c1086c9e8e5589bc70 to master with minor
modifications.

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bac90b1e07..ff85b3f2bf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -152,6 +152,7 @@ 
 ;;; Copyright © 2024 Adriel Dumas--Jondeau <leirda@disroot.org>
 ;;; Copyright © 2024 Navid Afkhami <navid.afkhami@mdc-berlin.de>
 ;;; Copyright © 2024 TakeV <takev@disroot.org>
+;;; Copyright © 2024 Markku Korkeala <markku.korkeala@iki.fi>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7417,6 +7418,43 @@  (define-public python-robotframework-seleniumscreenshots
 or for visual regression testing purposes.")
     (license license:bsd-3)))
 
+(define-public python-robotframework-requests
+  (package
+    (name "python-robotframework-requests")
+    (version "0.9.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/MarketSquare/robotframework-requests")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "077j8p5k41v53slyv8h32fcmqfi7m6z3r4gmyqqaawm5szfmy61m"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+                      (when tests?
+                        (invoke "pytest" "-v" "utests/")))))))
+    (propagated-inputs (list python-requests python-robotframework))
+    (native-inputs (list python-flask
+                         python-flask
+                         python-coverage
+                         python-flake8
+                         python-mock
+                         python-flake8
+                         python-pytest
+                         python-pytest-cov))
+    (home-page "https://github.com/MarketSquare/robotframework-requests")
+    (synopsis "Robot Framework keyword library wrapper around requests")
+    (description
+     "RequestsLibrary is a Robot Framework library aimed to provide HTTP
+     api testing functionalities by wrapping the well known Python
+     Requests Library.")
+    (license license:expat)))
+
 (define-public python-rstr
   (package
    (name "python-rstr")