diff mbox series

[bug#69842] gnu: Add go-github-com-multiformats-go-varint.

Message ID 1782b8c82eb20be7624c2fddf9123696deeaf199.1710677431.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#69842] gnu: Add go-github-com-multiformats-go-varint. | expand

Commit Message

Artyom V. Poptsov March 17, 2024, 12:10 p.m. UTC
* gnu/packages/golang.scm (go-github-com-multiformats-go-varint): New
  variable.

Change-Id: Ib2f82fff0fbed00010c2aa7993134d5a855f0d7d
---
 gnu/packages/golang.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: c5a8b46ffc535b7c3acc3dfa4af9ee275676dceb

Comments

Sharlatan Hellseher March 17, 2024, 1:42 p.m. UTC | #1
Hi,

Thank you for the patch.

Please avoid adding new packages into golang.scm, It is in a
 proces of redistribution among submodules.

Pick up any of golang-*.scm modules.

--
Oleg
Artyom V. Poptsov March 17, 2024, 2:36 p.m. UTC | #2
Hello!

> Please avoid adding new packages into golang.scm, It is in a
>  proces of redistribution among submodules.

I know that you're working on splitting Go packages between more
specific modules.

I placed the new package into "golang.scm" only because other
"go-github-com-multiformats-*" packages are placed here.

Maybe it's reasonable to move all "go-github-com-multiformats-*" to
"golang-xyz.scm" first and then place the new packages from this group
here.  What do you think?

Could you merge "go-github-com-multiformats-go-varint" after the review
process (and maybe with corrections to the package from my side) and
then move all "go-github-com-multiformats-*" to "golang-xyz.scm"?

Thanks!
- avp
Sharlatan Hellseher March 17, 2024, 4:23 p.m. UTC | #3
Hi,

> Could you merge "go-github-com-multiformats-go-varint" after the review
> process (and maybe with corrections to the package from my side) and
> then move all "go-github-com-multiformats-*" to "golang-xyz.scm"?

Sounds like a plan!
Let's wait until QA picking  it up and I'll move mentioned to golang-xyz.scm

-- 
VCS: https://github.incerto.xyz/; https://git.sr.ht/~hellseher/
GPG: 9847 81DE 689C 21C2 6418 0867 76D7 27BF F62C D2B5

… наш разум - превосходная объяснительная машина которая способна
найти смысл почти в чем угодно, истолковать любой феномен, но
совершенно не в состоянии принять мысль о непредсказуемости.
Sharlatan Hellseher March 21, 2024, 11:57 p.m. UTC | #4
Pushed as 791578befb7e129f682f38bfe903c23baa46fb91 to master.
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c386421bec..e78eb23a7a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5256,6 +5256,28 @@  (define-public go-github-com-multiformats-go-multiaddr-net
 as conversion to and from @command{net.Addr}.")
       (license license:expat))))
 
+(define-public go-github-com-multiformats-go-varint
+  (package
+    (name "go-github-com-multiformats-go-varint")
+    (version "0.0.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/multiformats/go-varint")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0l4s0z3rc3d350zp6qximl1jjhic6l8w74wkmx244jgfzsxd93af"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/mreiferson/go-options"))
+    (home-page "https://github.com/mreiferson/go-options")
+    (synopsis "Varint helpers that enforce minimal encoding")
+    (description
+     "Varint helpers that enforce minimal encoding.")
+    (license license:expat)))
+
 (define-public go-github-com-whyrusleeping-tar-utils
   (let ((commit "8c6c8ba81d5c71fd69c0f48dbde4b2fb422b6dfc")
         (revision "0"))