diff mbox series

[bug#61074] gnu: Add emacs-poke.

Message ID 1735d856d5d1f9bd306ac3fc882689e61b352dc7.1674725199.git.efraim@flashner.co.il
State New
Headers show
Series [bug#61074] gnu: Add emacs-poke. | expand

Commit Message

Efraim Flashner Jan. 26, 2023, 9:28 a.m. UTC
* gnu/packages/engineering.scm (emacs-poke): New variable.
(poke)[arguments]: Add configure-flag to install emacs files to
temporary directory.
---
 gnu/packages/engineering.scm | 22 +++++++++++++++++++++-
 1 file changed, 21 insertions(+), 1 deletion(-)


base-commit: a84ceaa8b2e8e121957afea1d1d3fe7c8141cb8d
prerequisite-patch-id: c10af8ba74fbbf48837769e71262382ada47dc71
prerequisite-patch-id: e001083279dec68d9710fb42bedfd710ab0ae707

Comments

Nicolas Goaziou Jan. 27, 2023, 8:59 a.m. UTC | #1
Hello,

Efraim Flashner <efraim@flashner.co.il> writes:

> * gnu/packages/engineering.scm (emacs-poke): New variable.
> (poke)[arguments]: Add configure-flag to install emacs files to
> temporary directory.

Thank you. I only have one nit.

> +    (description
> +     "This package provides two Emacs major modes for working with GNU Poke:
> +@code{poke-ras-mode.el} and @code{poke-map-mode.el}.")))

Here it is.

"poke-ras-mode.el" and "poke-map-mode.el" are not major modes, but
files. I suggest to obey to Emacs typography and use, respectively,
"Poke Ras mode" and "Poke Map mode".

I didn't try to build the package, but I assume you did already, and
qa.guix.gnu.org is not helpful at the moment.

Regards,
Efraim Flashner Jan. 30, 2023, 8:41 a.m. UTC | #2
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ff997a140d..15dc70d5ad 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2903,7 +2903,9 @@  (define-public poke
      ;; To enable the "hyperlink server", add the `--enable-hserver' flag.
      `(#:configure-flags
        '("--enable-mi"
-         "--disable-static")))
+         "--disable-static"
+         ;; The emacs files are provided in emacs-poke.
+         "--with-lispdir=/tmp/share/emacs")))
     (home-page "https://www.gnu.org/software/poke/#documentation")
     (synopsis "Editing of arbitrary binary data")
     (description "GNU poke is an interactive, extensible editor for binary data.
@@ -2912,6 +2914,24 @@  (define-public poke
 data structures and to operate on them.")
     (license license:gpl3+)))
 
+(define-public emacs-poke
+  (package
+    (inherit poke)
+    (name "emacs-poke")
+    (build-system emacs-build-system)
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-before 'expand-load-path 'change-working-directory
+             (lambda _ (chdir "etc"))))))
+    (inputs '())
+    (native-inputs '())
+    (synopsis "GNU Poke major modes for Emacs")
+    (description
+     "This package provides two Emacs major modes for working with GNU Poke:
+@code{poke-ras-mode.el} and @code{poke-map-mode.el}.")))
+
 (define-public pcb2gcode
   ;; Take some additional commits after v2.4.0 to fix build against
   ;; geos 3.10.1.