diff mbox series

[bug#42302] gnu: Add xssproxy

Message ID 173331594355886@mail.yandex.ru
State Accepted
Headers show
Series [bug#42302] gnu: Add xssproxy | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ivan Kozlov July 10, 2020, 4:49 a.m. UTC
xssproxy is a tiny daemon that provides an Idle Inhibition Service specification conformant D-Bus interface to libXss. It allows programs that support only this interface (like older Firefox and IceCat) to inhibit screen locking or blanking on systems without a conformant screen locker program.

* gnu/packages/xdisorg.scm (xssproxy): New variable.
---

Comments

Ludovic Courtès July 10, 2020, 8:49 p.m. UTC | #1
Hi,

Ivan Kozlov <kanichos@yandex.ru> skribis:

> xssproxy is a tiny daemon that provides an Idle Inhibition Service specification conformant D-Bus interface to libXss. It allows programs that support only this interface (like older Firefox and IceCat) to inhibit screen locking or blanking on systems without a conformant screen locker program.
>
> * gnu/packages/xdisorg.scm (xssproxy): New variable.

Nice!  Note: you don’t need to provide a description of the package in
the commit log.

Overall the patch looks good to me, modulo minor issues reported by
‘guix lint’ (see below for how to address them):

--8<---------------cut here---------------start------------->8---
gnu/packages/xdisorg.scm:1384:12: xssproxy@1.0.0: 'pkg-config' should probably be a native input
gnu/packages/xdisorg.scm:1368:12: xssproxy@1.0.0: the source file name should contain the package name
gnu/packages/xdisorg.scm:1368:12: xssproxy@1.0.0: the source URI should not be an autogenerated tarball
--8<---------------cut here---------------end--------------->8---

> +(define xssproxy

Use ‘define-public’ instead.

> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://github.com/timakro/xssproxy/archive/v"
> +                                  version
> +                                  ".tar.gz"))

Use ’git-fetch’ instead of ‘url-fetch’ to fetch the source over Git
instead of an autogenerated tarball, and add a ‘file-name’ field.

> +    (synopsis "Forward freedesktop.org Idle Inhibition Service calls to Xss")
> +    (description "xssproxy implements the org.freedesktop.ScreenSaver D-Bus interface
> +described in the Idle Inhibition Service Draft by the freedesktop.org developers.
> +The inhibition of the screensaver is then controlled using the XScreenSaverSuspend
> +function from the Xss (X11 Screen Saver extension) library.")

You can use markup for clarity, for instance
@code{org.freedesktop.ScreenSaver}.

Could you send an updated patch?

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index cec9bf0799..3e71b07636 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2020 John Soo <jsoo1@asu.edu>
 ;;; Copyright © 2020 Boris A. Dekshteyn <boris.dekshteyn@gmail.com>
 ;;; Copyright © 2020 Alex McGrath <amk@amk.ie>
+;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1360,6 +1361,40 @@  demos.  It also acts as a nice screen locker.")
                "http://metadata.ftp-master.debian.org/changelogs/"
                "/main/x/xscreensaver/xscreensaver_5.36-1_copyright")))))
 
+(define xssproxy
+  (package
+    (name "xssproxy")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/timakro/xssproxy/archive/v"
+                                  version
+                                  ".tar.gz"))
+              (sha256
+               (base32
+                "05pp9f0rx7g8gahqvr7krlfy90mlcb94ig4m5flmrfszwrr9v8k7"))))
+    (build-system gnu-build-system)
+    (arguments `(#:make-flags `("bindir=/bin"
+                                "man1dir=/share/man/man1"
+                                ,(string-append "DESTDIR=" (assoc-ref %outputs "out"))
+                                "CC=gcc")
+                 #:phases (modify-phases %standard-phases
+                            (delete 'configure)
+                            (delete 'check))))
+    (inputs `(("glib" ,glib)
+              ("pkg-config" ,pkg-config)
+              ("libx11" ,libx11)
+              ("libxext" ,libxext)
+              ("libxscrnsaver" ,libxscrnsaver)
+              ("dbus" ,dbus)))
+    (synopsis "Forward freedesktop.org Idle Inhibition Service calls to Xss")
+    (description "xssproxy implements the org.freedesktop.ScreenSaver D-Bus interface
+described in the Idle Inhibition Service Draft by the freedesktop.org developers.
+The inhibition of the screensaver is then controlled using the XScreenSaverSuspend
+function from the Xss (X11 Screen Saver extension) library.")
+    (home-page "https://github.com/timakro/xssproxy")
+    (license license:gpl3+)))
+
 (define-public xsel
   (package
     (name "xsel")