diff mbox series

[bug#72435] gnu: vulkan-loader: Fix cross-compilation.

Message ID 172a868a23c4b90b46b56a5de8dff2a5dbc1df25.1722651834.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#72435] gnu: vulkan-loader: Fix cross-compilation. | expand

Commit Message

Zheng Junjie Aug. 3, 2024, 2:23 a.m. UTC
* gnu/packages/vulkan.scm (vulkan-loader)[arguments]<#:configure>: When
cross-compilation, set the PKG_CONFIG_EXECUTABLE variable.

Change-Id: Ie0466a64effa5c93f859ff872423f2403f23f5cb
---
 gnu/packages/vulkan.scm | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)


base-commit: b20956651a53a8f23828fdeb6945e1a31e6997a8

Comments

Christopher Baines Aug. 11, 2024, 10:36 a.m. UTC | #1
Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/vulkan.scm (vulkan-loader)[arguments]<#:configure>: When
> cross-compilation, set the PKG_CONFIG_EXECUTABLE variable.
>
> Change-Id: Ie0466a64effa5c93f859ff872423f2403f23f5cb
> ---
>  gnu/packages/vulkan.scm | 8 ++++++--
>  1 file changed, 6 insertions(+), 2 deletions(-)

Sounds good to me, I've pushed this to master as
0f82dfeb0abe2d1d7a0fc45d7e164c3842234820.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 25542c1e06..8aee673653 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -6,7 +6,7 @@ 
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2022 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;; Copyright © 2022, 2024 dan <i@dan.games>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -297,7 +297,11 @@  (define-public vulkan-loader
                                        (search-input-directory
                                         %build-inputs "include/vulkan"))))
               #$@(if (%current-target-system)
-                     #~("-DBUILD_TESTS=OFF" "-DUSE_GAS=OFF")
+                     #~("-DBUILD_TESTS=OFF" "-DUSE_GAS=OFF"
+                        (string-append "-DPKG_CONFIG_EXECUTABLE="
+                                       (search-input-file
+                                        %build-inputs
+                                        (string-append "bin/" #$(pkg-config-for-target)))))
                      #~("-DBUILD_TESTS=ON")))
        #:phases
        #~(modify-phases %standard-phases