[bug#76707] gnu: python-trimesh: Skip tests requiring network.

Message ID 172a68cc2a27cc08cd065b3cea8f683cb64c4f9a.1740989610.git.lars.bilke@ufz.de
State New
Headers
Series [bug#76707] gnu: python-trimesh: Skip tests requiring network. |

Commit Message

Lars Bilke March 3, 2025, 8:13 a.m. UTC
  * gnu/packages/python-science (python-trimesh): Skip network tests.

Change-Id: I82389eca3baf14322875daa9aa33f74a1066c8e3
---
 gnu/packages/python-science.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)


base-commit: c991c49f09d6fd2764e1f7bdae54c097c748524f
  

Comments

Guillaume Le Vaillant March 3, 2025, 1:55 p.m. UTC | #1
Patch applied as f203028ef869945b3d44f0f2f7b16d61d064190c.
Thanks.
  

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 679074c760..6f76181dcc 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -999,7 +999,10 @@  (define-public python-trimesh
                           "test_simple_open"
                           "test_slice_onplane"
                           "test_spline_3D"
-                          "test_svg")
+                          "test_svg"
+                          ;; Following tests require network:
+                          "test_fuze"
+                          "test_remote")
                     " and not "))
       #:phases
       #~(modify-phases %standard-phases