diff mbox series

[bug#37534] gnu: conky: Activate Pulseaudio support.

Message ID 1727802752.681659.1569661332406@mail.yahoo.com
State Accepted
Headers show
Series [bug#37534] gnu: conky: Activate Pulseaudio support. | expand

Commit Message

ashish.is--- via Guix-patches" via Sept. 28, 2019, 9:02 a.m. UTC
Hi Tobias
Thank you for the review and sorry to have missed the sorting.
I have re-attached the original patch as a file to this email, as I guess the encoding issues were caused by git send-mail.
  Thank you again,    Vasile

    On Saturday, September 28, 2019, 12:50:15 AM GMT+2, Tobias Geerinckx-Rice <me@tobias.gr> wrote:  
 
 Vasile,

Vasile Dumitrascu via Guix-patches via 写道:
> --- a/gnu/packages/conky.scm
> +++ b/gnu/packages/conky.scm
> @@ -2,6 +2,7 @@
>  ;;; Copyright ?? 2015 Sini??a Bi??in <sinisa@bidin.eu>
>  ;;; Copyright ?? 2018, 2019 Tobias Geerinckx-Rice 
>  <me@tobias.gr>
>  ;;; Copyright ?? 2019 Pierre Neidhardt <mail@ambrevar.xyz>
> +;;; Copyright ?? 2019 Vasile Dumitrascu <va511e@yahoo.com>

Does this show up as corrupted in your mailbox as well?  (‘??’ 
instead of ‘©’.)

> @@ -76,6 +79,7 @@
>        ("libxext" ,libxext)
>        ("libxft" ,libxft)
>        ("libxinerama" ,libxinerama)
> +      ("pulseaudio", pulseaudio)
>        ("lua" ,lua)
>        ("ncurses" ,ncurses)
>        ("curl" ,curl)))

I guess any hope of alphabetical ordering was lost long ago.

The change looks fine to me, but could you try fixing the text 
encoding?

Thanks!

T G-R

Comments

ashish.is--- via Guix-patches" via Oct. 1, 2019, 4:16 p.m. UTC | #1
Vasile,

Thanks for the patch!  I've pushed it as 
18edc9db02658c597695905121a9df68e9118ab8 with miniscule changes to 
the commit message.

Dumitrascu Vasile 写道:
>   Hi Tobias
> Thank you for the review and sorry to have missed the sorting.

Oh, er, sorry you're sorry; no need to be.  All I meant by ‘any 
hope lost’ was that there's no way to make the entire list sorted 
without moving unrelated lines around (e.g. curl).  But your new 
compromise is a better compromise.  Thank you!

> I have re-attached the original patch as a file to this email, 
> as I guess the encoding issues were caused by git send-mail.

‘git send-email’ has one job, so it should do it really well.  I 
send all my patches in-line and have never had trouble.

Kind regards,

T G-R
diff mbox series

Patch

From ddd14f92faa6298f93ded11ff1f96b34f847a549 Mon Sep 17 00:00:00 2001
From: Vasile Dumitrascu <va511e@yahoo.com>
Date: Fri, 27 Sep 2019 22:32:05 +0200
Subject: [PATCH] gnu: conky: Activate Pulseaudio support.

* gnu/packages/conky.scm (conky):
  [inputs] Add pulseaudio.
---
 gnu/packages/conky.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/conky.scm b/gnu/packages/conky.scm
index 681feb6e43..046d132a9b 100644
--- a/gnu/packages/conky.scm
+++ b/gnu/packages/conky.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,6 +32,7 @@ 
   #:use-module (gnu packages lua)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages xorg))
 
 (define-public conky
@@ -51,7 +53,8 @@ 
     (arguments
      `(#:tests? #f                      ; there are no tests
        #:configure-flags
-       (list "-DRELEASE=true")
+       (list "-DRELEASE=true"
+             "-DBUILD_PULSEAUDIO=ON")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'add-freetype-to-search-path
@@ -76,6 +79,7 @@ 
        ("libxext" ,libxext)
        ("libxft" ,libxft)
        ("libxinerama" ,libxinerama)
+       ("pulseaudio", pulseaudio)
        ("lua" ,lua)
        ("ncurses" ,ncurses)
        ("curl" ,curl)))
-- 
2.23.0