diff mbox series

[bug#71781,v2,28/28] gnu: Add mozo.

Message ID 16eda9b5b46eb37954c7f4859c3f872a110f9242.1719390794.git.atai@atai.org
State New
Headers show
Series Update Mate Desktop to 1.28 | expand

Commit Message

Andy Tai June 26, 2024, 8:36 a.m. UTC
* gnu/packages/mate.scm (mozo): New variable.
  (mate)[inputs]: Add mozo.

Change-Id: I317b3479b44b1b02abf814fa5b871faa436913a6
---
 gnu/packages/mate.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index b0396e5397..fa1f85b432 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1514,6 +1514,33 @@  (define-public mate-polkit-for-xfce
                (rename-file old new)))))))
     (properties `((hidden? . #t)))))
 
+
+(define-public mozo
+  (package
+    (name "mozo")
+    (version "1.28.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://mate/" (version-major+minor version) "/"
+                           "mozo-" version ".tar.xz"))
+       (sha256
+        (base32 "0929yk7g7103d18p400ysi19pqrxl3dyzg4l0mnw7a3azm7ri67y"))))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     (list pkg-config))
+    (inputs
+     (list gettext-minimal
+           mate-menus
+           python
+           python-pygobject))
+    (home-page "https://mate-desktop.org/")
+    (synopsis "Menu editor for MATE")
+    (description "Mozo is a menu editor for MATE using the freedesktop.org menu
+specification")
+    (license (list license:lgpl2.0+))))
+
+
 (define-public mate
   (package
     (name "mate")
@@ -1572,6 +1599,7 @@  (define-public mate
                    mate-polkit
                    mate-system-monitor
                    mate-utils
+                   mozo
                    pluma
                    pinentry-gnome3
                    pulseaudio